# CVE-2026-44716: Pipecat: Path Traversal in Pipecat Runner `/files` Endpoint — Arbitrary File Read via `%2F`-Encoded Separator

> Attackers can read arbitrary files via path traversal in the Pipecat runner's file endpoint when the folder flag is used.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** GHSA-3363-2ph6-35wh, PYSEC-2026-2877

## What is CVE-2026-44716?

CVE-2026-44716 is a high-severity path traversal vulnerability in pipecat-ai pipecat, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pipecat is an open-source Python framework for building real-time voice and multimodal conversational agents. From version 0.0.90 to before version 1.2.0, a path traversal vulnerability exists in Pipecat's development runner (src/pipecat/runner/run.py). When the runner is started with the --folder flag, it exposes a GET /files/{filename:path} download endpoint. The filename path parameter is concatenated directly onto args.folder with no containment check. Starlette normalises literal ../ sequences in URLs, but %2F-encoded slashes bypass this normalisation: the path parameter is URL-decoded after routing, so ..%2F..%2Fetc%2Fpasswd resolves to a path two levels above args.folder. An attacker with network access to the runner can read any file the pipecat process has permission to access — including SSH private keys, credentials, and system files — with a single unauthenticated HTTP request. This issue has been patched in version 1.2.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-44716?

3 open source packages ship an affected version, including pipecat-ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pipecat-ai` | PyPI | From 0.0.90 | 1.2.0 |
| `pipecat-ai` | PyPI | From 0.0.90 | 1.2.0 |
| `pipecat-ai` | PyPI | From 0.0.90 | 1.2.0 |

Products: Pipecat Pipecat.

## How do I fix CVE-2026-44716?

Upgrade pipecat-ai to 1.2.0 or later.

## Is CVE-2026-44716 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44716 exists.

## Other vulnerabilities in pipecat-ai pipecat

- [CVE-2025-62373](https://insights.sbomify.com/CVE-2025-62373/): Pipecat vulnerable to Remote Code Execution by Pickle Deserialization via LivekitFrameSerializer (critical 9.8)
- [CVE-2026-54695](https://insights.sbomify.com/CVE-2026-54695/): Pipecat: Telephony WebSocket `/ws` Unauthenticated Call-Control Abuse via Attacker-Supplied Call SID (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44716 and fix it if it is affected.

What it is: CVE-2026-44716 is a high-severity path traversal vulnerability in pipecat-ai pipecat, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44716 exists.

Affected packages and fixed versions:
- pipecat-ai (PyPI): affected from 0.0.90; fixed in 1.2.0
- pipecat-ai (PyPI): affected from 0.0.90; fixed in 1.2.0
- pipecat-ai (PyPI): affected from 0.0.90; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44716/ (Markdown: https://insights.sbomify.com/CVE-2026-44716/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44716
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44716
- OSV: https://osv.dev/vulnerability/CVE-2026-44716

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44716/
Summaries are generated and may contain mistakes; the official description above is the record.
