# CVE-2026-44717: MCP Calculate Server: Prompt Injection to RCE

> Attackers can execute arbitrary code via prompt injection in the MCP Calculate Server due to unsafe eval usage.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 May 2026
- **Updated:** 15 May 2026

## What is CVE-2026-44717?

CVE-2026-44717 is a critical code injection vulnerability in 611711Dark mcp_calculate_server, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MCP Calculate Server is a mathematical calculation service based on MCP protocol and SymPy library. Prior to 0.1.1, the use of eval() to evaluate mathematical expressions without proper input sanitization leads to remote code execution. This vulnerability is fixed in 0.1.1.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1427 (Improper Neutralization of Input Used for LLM Prompting)

## Which versions are affected by CVE-2026-44717?


## How do I fix CVE-2026-44717?

No fix has been published for CVE-2026-44717 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44717 being exploited?

There is no known exploitation of CVE-2026-44717 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44717 and fix it if it is affected.

What it is: CVE-2026-44717 is a critical code injection vulnerability in 611711Dark mcp_calculate_server, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44717 in the wild and no public exploit code.

Affected product: 611711Dark mcp_calculate_server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44717/ (Markdown: https://insights.sbomify.com/CVE-2026-44717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44717
- OSV: https://osv.dev/vulnerability/CVE-2026-44717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44717/
Summaries are generated and may contain mistakes; the official description above is the record.
