# CVE-2026-44720: OpenLearnX: Critical Authentication Bypass via JWT Signature Verification Disabled Leading to Account Takeover

> Attackers can bypass authentication and take over user accounts due to disabled JWT signature verification in OpenLearnX.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-223g-f5mq-gw33

## What is CVE-2026-44720?

CVE-2026-44720 is a medium-severity authentication bypass vulnerability in th30d4y OpenLearnX, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenLearnX is an open-source, decentralized learning and assessment platform. Prior to 2.0.4, a critical authentication vulnerability was identified in OpenLearnX that could allow unauthorized access to user accounts under specific conditions. This vulnerability is fixed in 2.0.4.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-44720?

2 open source packages ship an affected version, including openlearnx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openlearnx` | npm | All versions | 2.0.4 |
| `openlearnx` | npm | All versions | 2.0.4 |

## How do I fix CVE-2026-44720?

Upgrade openlearnx to 2.0.4 or later.

## Is CVE-2026-44720 being exploited?

There is no known exploitation of CVE-2026-44720 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44720 and fix it if it is affected.

What it is: CVE-2026-44720 is a medium-severity authentication bypass vulnerability in th30d4y OpenLearnX, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44720 in the wild and no public exploit code.

Affected packages and fixed versions:
- openlearnx (npm): affected all versions; fixed in 2.0.4
- openlearnx (npm): affected all versions; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44720/ (Markdown: https://insights.sbomify.com/CVE-2026-44720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44720
- OSV: https://osv.dev/vulnerability/CVE-2026-44720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44720/
Summaries are generated and may contain mistakes; the official description above is the record.
