# CVE-2026-44722: pyzipper: Encryption bypass for small files encrypted with pyzipper

> An operator precedence bug in pyzipper caused AES-encrypted files to use a weaker format, exposing CRC32 checksums that allow attackers to brute-force plaintext for small files.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-44722, GHSA-crqm-m339-7m2p, PYSEC-2026-3044, UBUNTU-CVE-2026-44722

## What is CVE-2026-44722?

CVE-2026-44722 is a medium-severity vulnerability in danifus pyzipper, published on 17 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pyzipper is a replacement for Python's zipfile that can read and write AES encrypted zip files. Prior to 0.4.0, a Python operator precedence bug in pyzipper/zipfile_aes.py caused the AE-2 format to never be automatically selected during encryption, causing encrypted entries to be written in AE-1 format and exposing the plaintext CRC32 checksum in the ZIP header and, for unseekable zip archives, in the datadescripter section, allowing an attacker who possesses the archive to brute-force candidate plaintexts for small or low-entropy files by comparing CRC32 values. This issue is fixed in version 0.4.0.

Weakness: CWE-480 (Use of Incorrect Operator)

## Which versions are affected by CVE-2026-44722?

3 open source packages ship an affected version, including pyzipper.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyzipper` | PyPI | All versions | 0.4.0 |
| `pyzipper` | PyPI | All versions | 0.4.0 |
| `pyzipper` | PyPI | All versions | 0.4.0 |

## How do I fix CVE-2026-44722?

Upgrade pyzipper to 0.4.0 or later.

## Is CVE-2026-44722 being exploited?

There is no known exploitation of CVE-2026-44722 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44722 and fix it if it is affected.

What it is: CVE-2026-44722 is a medium-severity vulnerability in danifus pyzipper, published on 17 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44722 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyzipper (PyPI): affected all versions; fixed in 0.4.0
- pyzipper (PyPI): affected all versions; fixed in 0.4.0
- pyzipper (PyPI): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44722/ (Markdown: https://insights.sbomify.com/CVE-2026-44722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44722
- OSV: https://osv.dev/vulnerability/CVE-2026-44722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44722/
Summaries are generated and may contain mistakes; the official description above is the record.
