# CVE-2026-44725: EMQX: Stale plugins allow grants amplify a compromised admin/API key to remote code execution

> An attacker with compromised admin credentials can exploit stale plugin grants to upload malicious code and achieve remote code execution on the EMQX broker.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-cp9x-5qwc-fj6r

## What is CVE-2026-44725?

CVE-2026-44725 is a medium-severity code injection vulnerability in emqx, published on 20 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

EMQX is a scalable and reliable MQTT broker for AI, IoT, IIoT, and connected vehicles. Prior to versions 5.8.11, 5.9.3, 5.10.4, 6.0.3, 6.1.2, and 6.2.1, the plugin-install REST API and dashboard upload accepted stale grants created with emqx ctl plugins allow because there was no five-minute grant lifetime or SHA-256 package binding. An attacker with a compromised dashboard administrator credential or API key with plugin-install permission who finds a stale allowed name and version can upload attacker-controlled bytes under the allowed .tar.gz filename through POST /api/v5/plugins/install or the dashboard plugin upload. The broker then installs and runs attacker-controlled Erlang code with the privileges of the EMQX process. This issue is fixed in versions 5.8.11, 5.9.3, 5.10.4, 6.0.3, 6.1.2, and 6.2.1.

Weakness: CWE-672 (Operation on a Resource after Expiration or Release), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-44725?


## How do I fix CVE-2026-44725?

No fix has been published for CVE-2026-44725 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44725 being exploited?

There is no known exploitation of CVE-2026-44725 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44725 and fix it if it is affected.

What it is: CVE-2026-44725 is a medium-severity code injection vulnerability in emqx, published on 20 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44725 in the wild and no public exploit code.

Affected product: emqx. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44725/ (Markdown: https://insights.sbomify.com/CVE-2026-44725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44725
- OSV: https://osv.dev/vulnerability/CVE-2026-44725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44725/
Summaries are generated and may contain mistakes; the official description above is the record.
