# CVE-2026-44726: Deno: TLS retry copies stale upgrade hook, risking plaintext traffic

> A network attacker can force plaintext transmission in Deno's TLS layer by triggering a connection retry, allowing them to observe or tamper with supposedly encrypted traffic.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-chqv-56wv-7564, JLSEC-2026-654

## What is CVE-2026-44726?

CVE-2026-44726 is a high-severity vulnerability in denoland deno, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime. From 2.0.0 until 2.7.8, a flaw in Deno's Node.js tls compatibility layer could cause a TLS client to transmit application data in plaintext after a connection retry. When `autoSelectFamily was enabled and the first address-family attempt failed, the socket reinitialization path reused a stale TLS upgrade hook that was bound to the original, failed handle. As a result, the replacement TCP connection was never upgraded to TLS, and any data the application wrote before the secureConnect event travelled over the network unencrypted. A network attacker positioned to cause the initial connection attempt to fail (for example, by dropping IPv6 traffic on a dual-stack host) could deterministically trigger the fallback path and observe or tamper with traffic that the application believed was TLS-protected. This vulnerability is fixed in 2.7.8.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2026-44726?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | From 2.0.0 | 2.7.8 |
| `deno` | crates.io | From 2.0.0 | 2.7.8 |

Products: Deno Deno.

## How do I fix CVE-2026-44726?

Upgrade deno to 2.7.8 or later.

## Is CVE-2026-44726 being exploited?

There is no known exploitation of CVE-2026-44726 in the wild and no public exploit code.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44726 and fix it if it is affected.

What it is: CVE-2026-44726 is a high-severity vulnerability in denoland deno, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44726 in the wild and no public exploit code.

Affected packages and fixed versions:
- deno (crates.io): affected from 2.0.0; fixed in 2.7.8
- deno (crates.io): affected from 2.0.0; fixed in 2.7.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44726/ (Markdown: https://insights.sbomify.com/CVE-2026-44726/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44726
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44726
- OSV: https://osv.dev/vulnerability/CVE-2026-44726

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44726/
Summaries are generated and may contain mistakes; the official description above is the record.
