CVE-2026-44727 Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP

Critical 9.3 Published Updated

Stored XSS in Jupyter Server allows attackers to execute arbitrary code and take over accounts via malicious notebook outputs.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-44727?

CVE-2026-44727 is a critical cross-site scripting vulnerability in jupyter-server jupyter_server, published on 22 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Jupyter Server is the backend for Jupyter web applications. Prior to 2.20, the nbconvert HTTP handlers in jupyter_server render user-authored notebook HTML under the Jupyter origin without a sandbox directive in their Content-Security-Policy. Combined with nbconvert.HTMLExporter's default non-sanitizing behavior, a notebook carrying an HTML payload in a display_data output triggers stored XSS with cookie access, full /api/* authority, and kernel RCE. This vulnerability is fixed in 2.20.

Weakness: CWE-79, CWE-1021

Which versions are affected by CVE-2026-44727?

3 open source packages ship an affected version, including jupyter-server. It affects 1 product.

PackageAffectedFixed in
jupyter-server PyPIAll versions2.20.0
jupyter-server PyPIAll versions2.20.0
jupyter-server PyPIAll versions2.20.0
Linux distribution packages (1)
python-jupyter-server openSUSE:TumbleweedAll versions2.20.0-1.1

Products include Jupyter Jupyter Server.

How do I fix CVE-2026-44727?

Upgrade jupyter-server to 2.20.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-44727 being exploited?

There is no known exploitation of CVE-2026-44727 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-SY39659, DEBIAN-CVE-2026-44727, GHSA-fcw5-x6j4-ccmp, MINI-j8c7-wwpp-pf9r, OESA-2026-3954, OESA-2026-3955 and 4 more.

Is CVE-2026-44727 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free