{"answers":{"affected":"3 open source packages ship an affected version, including pycti. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44730 in the wild and no public exploit code.","fix":"Upgrade pycti to 6.9.7 or later.","what":"CVE-2026-44730 is a high-severity vulnerability in OpenCTI-Platform opencti, published on 26 May 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44730 and fix it if it is affected.\n\nWhat it is: CVE-2026-44730 is a high-severity vulnerability in OpenCTI-Platform opencti, published on 26 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44730 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pycti (PyPI): affected all versions; fixed in 6.9.7\n- pycti (PyPI): affected all versions; fixed in 6.9.7\n- pycti (PyPI): affected all versions; fixed in 6.9.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44730/ (Markdown: https://insights.sbomify.com/CVE-2026-44730/index.md)","id":"CVE-2026-44730","markdown":"https://insights.sbomify.com/CVE-2026-44730/index.md","name":"CVE-2026-44730","record":{"aliases":["GHSA-q537-qhj4-wcjx","PYSEC-2026-167"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Threat Intelligence Platform","requires_auth":"high_privilege","summary":"Organization admins can escalate privileges by adding high-privilege users from other organizations due to incorrect ACLs on the GraphQL API.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opencti","vendor":"citeum"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to 6.9.7, an organization admin can escalate their privileges by adding a user from a different organization with higher privileges, to their own organization. This is due to incorrect ACL on userEdit relationAdd. This vulnerability is fixed in 6.9.7.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenCTI: Privilege escalation via graphQL API is abusable by organization admins, due to incorrect ACL on userEdit relationAdd","id":"CVE-2026-44730","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Information disclosure in openproject","id":"CVE-2026-44731"},"packages":[{"ecosystem":"PyPI","fixed":["6.9.7"],"introduced":["0"],"last_affected":[],"package":"pycti","purl":null,"source":"GHSA-q537-qhj4-wcjx"},{"ecosystem":"PyPI","fixed":["6.9.7"],"introduced":["0"],"last_affected":[],"package":"pycti","purl":"pkg:pypi/pycti","source":"GHSA-q537-qhj4-wcjx"},{"ecosystem":"PyPI","fixed":["6.9.7"],"introduced":["0"],"last_affected":[],"package":"pycti","purl":"pkg:pypi/pycti","source":"PYSEC-2026-167"}],"prev":{"headline":"Twenty: Stored Cross-Site Scripting via Unsanitized File Serving (Missing Content-Type/Content-Disposition Headers)","id":"CVE-2026-44729"},"products":["opencti"],"published":"2026-05-26","related":[{"cvss_score":9.8,"headline":"OpenCTI privilege escalation and unauthenticated access via default admin account","id":"CVE-2026-27960","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":9.1,"headline":"OpenCTI affected by RCE via notifier template","id":"CVE-2026-39980","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":9.1,"headline":"OpenCTI has remote code execution and sensitive secrets exposed through web hook","id":"CVE-2025-24977","kev_date_added":null,"published":"2025-05-05"},{"cvss_score":8.3,"headline":"OpenCTI Authenticated Privilege Escalation","id":"CVE-2024-26139","kev_date_added":null,"published":"2024-05-23"},{"cvss_score":8.1,"headline":"OpenCTI's lack of Rate Limit lead to OTP brute forcing","id":"CVE-2024-45404","kev_date_added":null,"published":"2024-12-11"},{"cvss_score":7.7,"headline":"OpenCTI has a Semi-Blind SSRF via Unvalidated External URL in Data Ingestion Feature","id":"CVE-2026-21887","kev_date_added":null,"published":"2026-03-12"},{"cvss_score":7.6,"headline":"OpenCTI vulnerable to Denial of Service through web hook","id":"CVE-2025-26621","kev_date_added":null,"published":"2025-05-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["OpenCTI-Platform"]},"summary":"Organization admins can escalate privileges by adding high-privilege users from other organizations due to incorrect ACLs on the GraphQL API.","url":"https://insights.sbomify.com/CVE-2026-44730/"}