# CVE-2026-44730: OpenCTI: Privilege escalation via graphQL API is abusable by organization admins, due to incorrect ACL on userEdit relationAdd

> Organization admins can escalate privileges by adding high-privilege users from other organizations due to incorrect ACLs on the GraphQL API.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-q537-qhj4-wcjx, PYSEC-2026-167

## What is CVE-2026-44730?

CVE-2026-44730 is a high-severity vulnerability in OpenCTI-Platform opencti, published on 26 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to 6.9.7, an organization admin can escalate their privileges by adding a user from a different organization with higher privileges, to their own organization. This is due to incorrect ACL on userEdit relationAdd. This vulnerability is fixed in 6.9.7.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-44730?

3 open source packages ship an affected version, including pycti. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycti` | PyPI | All versions | 6.9.7 |
| `pycti` | PyPI | All versions | 6.9.7 |
| `pycti` | PyPI | All versions | 6.9.7 |

Products: Citeum Opencti.

## How do I fix CVE-2026-44730?

Upgrade pycti to 6.9.7 or later.

## Is CVE-2026-44730 being exploited?

There is no known exploitation of CVE-2026-44730 in the wild and no public exploit code.

## Other vulnerabilities in OpenCTI-Platform opencti

- [CVE-2026-27960](https://insights.sbomify.com/CVE-2026-27960/): OpenCTI privilege escalation and unauthenticated access via default admin account (critical 9.8)
- [CVE-2026-39980](https://insights.sbomify.com/CVE-2026-39980/): OpenCTI affected by RCE via notifier template (critical 9.1)
- [CVE-2025-24977](https://insights.sbomify.com/CVE-2025-24977/): OpenCTI has remote code execution and sensitive secrets exposed through web hook (critical 9.1)
- [CVE-2024-26139](https://insights.sbomify.com/CVE-2024-26139/): OpenCTI Authenticated Privilege Escalation (high 8.3)
- [CVE-2024-45404](https://insights.sbomify.com/CVE-2024-45404/): OpenCTI's lack of Rate Limit lead to OTP brute forcing (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44730 and fix it if it is affected.

What it is: CVE-2026-44730 is a high-severity vulnerability in OpenCTI-Platform opencti, published on 26 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44730 in the wild and no public exploit code.

Affected packages and fixed versions:
- pycti (PyPI): affected all versions; fixed in 6.9.7
- pycti (PyPI): affected all versions; fixed in 6.9.7
- pycti (PyPI): affected all versions; fixed in 6.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44730/ (Markdown: https://insights.sbomify.com/CVE-2026-44730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44730
- OSV: https://osv.dev/vulnerability/CVE-2026-44730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44730/
Summaries are generated and may contain mistakes; the official description above is the record.
