{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44737 exists.","fix":"Upgrade getgrav/grav to 1.7.49.5 or later.","what":"CVE-2026-44737 is a medium-severity cross-site scripting vulnerability in getgrav grav-plugin-admin, published on 11 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44737 and fix it if it is affected.\n\nWhat it is: CVE-2026-44737 is a medium-severity cross-site scripting vulnerability in getgrav grav-plugin-admin, published on 11 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44737 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 1.7.49.5\n- getgrav/grav (Packagist): affected all versions; fixed in 1.7.49.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44737/ (Markdown: https://insights.sbomify.com/CVE-2026-44737/index.md)","id":"CVE-2026-44737","markdown":"https://insights.sbomify.com/CVE-2026-44737/index.md","name":"CVE-2026-44737","record":{"aliases":["GHSA-fmg2-f5r9-24qc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav admin plugin","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts via the page title parameter, leading to script execution in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.2,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"grav-plugin-admin is the admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.10.49.5, the application fails to properly validate and sanitize user input in the data[header][title] parameter. As a result, attackers can craft a malicious URL with an XSS payload. When this URL is accessed, the injected script is reflected back in the HTTP response and executed within the context of the victim's browser session. This vulnerability is fixed in 1.10.49.5.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav: Stored XSS via page title (data[header][title]) in admin panel","id":"CVE-2026-44737","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Grav: Twig sandbox allows editor-role users to exfiltrate all plugin secrets via Config::toArray()","id":"CVE-2026-44738"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.49.5"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-fmg2-f5r9-24qc"},{"ecosystem":"Packagist","fixed":["1.7.49.5"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-fmg2-f5r9-24qc"}],"prev":{"headline":"OpenProject: Relations API Filter Bypasses Visibility Scope, Leaking Cross-Project Work Package Subjects","id":"CVE-2026-44736"},"products":["grav-plugin-admin"],"published":"2026-05-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["getgrav"]},"summary":"Attackers can inject malicious scripts via the page title parameter, leading to script execution in victim browsers.","url":"https://insights.sbomify.com/CVE-2026-44737/"}