# CVE-2026-44737: Grav: Stored XSS via page title (data[header][title]) in admin panel

> Attackers can inject malicious scripts via the page title parameter, leading to script execution in victim browsers.

- **Severity:** Medium 6.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-fmg2-f5r9-24qc

## What is CVE-2026-44737?

CVE-2026-44737 is a medium-severity cross-site scripting vulnerability in getgrav grav-plugin-admin, published on 11 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

grav-plugin-admin is the admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.10.49.5, the application fails to properly validate and sanitize user input in the data[header][title] parameter. As a result, attackers can craft a malicious URL with an XSS payload. When this URL is accessed, the injected script is reflected back in the HTTP response and executed within the context of the victim's browser session. This vulnerability is fixed in 1.10.49.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-44737?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.7.49.5 |
| `getgrav/grav` | Packagist | All versions | 1.7.49.5 |

## How do I fix CVE-2026-44737?

Upgrade getgrav/grav to 1.7.49.5 or later.

## Is CVE-2026-44737 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44737 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44737 and fix it if it is affected.

What it is: CVE-2026-44737 is a medium-severity cross-site scripting vulnerability in getgrav grav-plugin-admin, published on 11 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44737 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.49.5
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.49.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44737/ (Markdown: https://insights.sbomify.com/CVE-2026-44737/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44737
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44737
- OSV: https://osv.dev/vulnerability/CVE-2026-44737

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44737/
Summaries are generated and may contain mistakes; the official description above is the record.
