# CVE-2026-44738: Grav: Twig sandbox allows editor-role users to exfiltrate all plugin secrets via Config::toArray()

> Editor-role users can exfiltrate sensitive plugin secrets like API keys and passwords by calling Config::toArray() in page content.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-j274-39qw-32c9

## What is CVE-2026-44738?

CVE-2026-44738 is a high-severity vulnerability in Getgrav Grav, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 2.0.0-rc.2, the Twig sandbox allow-list permits any user with the admin.pages role to call config.toArray() from within a page body, dumping the entire merged site configuration — including all plugin secrets (SMTP passwords, AWS keys, OAuth client secrets, API tokens) — into the rendered HTML. No administrator privileges are required. This vulnerability is fixed in 2.0.0-rc.2.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-44738?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.0-rc.2 |
| `getgrav/grav` | Packagist | All versions | 2.0.0-rc.2 |

Products: Getgrav Grav.

## How do I fix CVE-2026-44738?

Upgrade getgrav/grav to 2.0.0-rc.2 or later.

## Is CVE-2026-44738 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44738 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44738 and fix it if it is affected.

What it is: CVE-2026-44738 is a high-severity vulnerability in Getgrav Grav, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44738 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-rc.2
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-rc.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44738/ (Markdown: https://insights.sbomify.com/CVE-2026-44738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44738
- OSV: https://osv.dev/vulnerability/CVE-2026-44738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44738/
Summaries are generated and may contain mistakes; the official description above is the record.
