CVE-2026-44741 Pimcore Admin Classic Bundle Vulnerable to SQL Injection in Translation Grid Date Filter via Unsanitized Property Parameter
Attackers can execute arbitrary SQL commands via the translation grid date filter, potentially reading or modifying database contents.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44741?
CVE-2026-44741 is a high-severity SQL injection vulnerability in pimcore, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Pimcore's Admin Classic Bundle provides a Backend UI for Pimcore. Versions prior to 2.3.6 and 1.7.18 have a SQL injection vulnerability in Pimcore's translation grid date filter — the user-supplied `property` field from the filter JSON is interpolated directly into a `UNIX_TIMESTAMP(DATE(FROM_UNIXTIME(...)))` SQL expression without parameterization or allowlist validation. Versiosn 2.3.6 and 1.7.18 fix the issue.
Weakness: CWE-89
Which versions are affected by CVE-2026-44741?
4 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle.
| Package | Affected | Fixed in |
|---|---|---|
pimcore/admin-ui-classic-bundle Packagist | All versions | 1.7.18 |
pimcore/admin-ui-classic-bundle Packagist | All versions | 1.7.18 |
pimcore/admin-ui-classic-bundle Packagist | From 2.0.0-RC1 | 2.3.6 |
pimcore/admin-ui-classic-bundle Packagist | From 2.0.0-RC1 | 2.3.6 |
How do I fix CVE-2026-44741?
Upgrade pimcore/admin-ui-classic-bundle to a fixed version for your release line: 1.7.18 or 2.3.6.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-44741 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44741 exists.
Sources
Also known as GHSA-h4ph-crvj-9h92.