{"answers":{"affected":"4 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44741 exists.","fix":"Upgrade pimcore/admin-ui-classic-bundle to a fixed version for your release line: 1.7.18 or 2.3.6.","what":"CVE-2026-44741 is a high-severity SQL injection vulnerability in pimcore, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44741 and fix it if it is affected.\n\nWhat it is: CVE-2026-44741 is a high-severity SQL injection vulnerability in pimcore, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44741 exists.\n\nAffected packages and fixed versions:\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.18\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.18\n- pimcore/admin-ui-classic-bundle (Packagist): affected from 2.0.0-RC1; fixed in 2.3.6\n- pimcore/admin-ui-classic-bundle (Packagist): affected from 2.0.0-RC1; fixed in 2.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44741/ (Markdown: https://insights.sbomify.com/CVE-2026-44741/index.md)","id":"CVE-2026-44741","markdown":"https://insights.sbomify.com/CVE-2026-44741/index.md","name":"CVE-2026-44741","record":{"aliases":["GHSA-h4ph-crvj-9h92"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore Admin Bundle","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary SQL commands via the translation grid date filter, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Pimcore's Admin Classic Bundle provides a Backend UI for Pimcore. Versions prior to 2.3.6 and 1.7.18 have a SQL injection vulnerability in Pimcore's translation grid date filter — the user-supplied `property` field from the filter JSON is interpolated directly into a `UNIX_TIMESTAMP(DATE(FROM_UNIXTIME(...)))` SQL expression without parameterization or allowlist validation. Versiosn 2.3.6 and 1.7.18 fix the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Pimcore Admin Classic Bundle Vulnerable to SQL Injection in Translation Grid Date Filter via Unsanitized Property Parameter","id":"CVE-2026-44741","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"Postorius is vulnerable to XSS","id":"CVE-2026-44742"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.18"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":null,"source":"GHSA-h4ph-crvj-9h92"},{"ecosystem":"Packagist","fixed":["1.7.18"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":"pkg:composer/pimcore/admin-ui-classic-bundle","source":"GHSA-h4ph-crvj-9h92"},{"ecosystem":"Packagist","fixed":["2.3.6"],"introduced":["2.0.0-RC1"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":null,"source":"GHSA-h4ph-crvj-9h92"},{"ecosystem":"Packagist","fixed":["2.3.6"],"introduced":["2.0.0-RC1"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":"pkg:composer/pimcore/admin-ui-classic-bundle","source":"GHSA-h4ph-crvj-9h92"}],"prev":{"headline":"go-billy: Lack of depth and cycle detection in symlink resolution may lead to infinite loops and resource exhaustion","id":"CVE-2026-44740"},"products":["pimcore"],"published":"2026-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-12","vendors":["pimcore"]},"summary":"Attackers can execute arbitrary SQL commands via the translation grid date filter, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2026-44741/"}