# CVE-2026-44741: Pimcore Admin Classic Bundle Vulnerable to SQL Injection in Translation Grid Date Filter via Unsanitized Property Parameter

> Attackers can execute arbitrary SQL commands via the translation grid date filter, potentially reading or modifying database contents.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** GHSA-h4ph-crvj-9h92

## What is CVE-2026-44741?

CVE-2026-44741 is a high-severity SQL injection vulnerability in pimcore, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pimcore's Admin Classic Bundle provides a Backend UI for Pimcore. Versions prior to 2.3.6 and 1.7.18 have a SQL injection vulnerability in Pimcore's translation grid date filter — the user-supplied `property` field from the filter JSON is interpolated directly into a `UNIX_TIMESTAMP(DATE(FROM_UNIXTIME(...)))` SQL expression without parameterization or allowlist validation. Versiosn 2.3.6 and 1.7.18 fix the issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-44741?

4 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.7.18 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.7.18 |
| `pimcore/admin-ui-classic-bundle` | Packagist | From 2.0.0-RC1 | 2.3.6 |
| `pimcore/admin-ui-classic-bundle` | Packagist | From 2.0.0-RC1 | 2.3.6 |

## How do I fix CVE-2026-44741?

Upgrade pimcore/admin-ui-classic-bundle to a fixed version for your release line: 1.7.18 or 2.3.6.

## Is CVE-2026-44741 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44741 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44741 and fix it if it is affected.

What it is: CVE-2026-44741 is a high-severity SQL injection vulnerability in pimcore, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44741 exists.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.18
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.18
- pimcore/admin-ui-classic-bundle (Packagist): affected from 2.0.0-RC1; fixed in 2.3.6
- pimcore/admin-ui-classic-bundle (Packagist): affected from 2.0.0-RC1; fixed in 2.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44741/ (Markdown: https://insights.sbomify.com/CVE-2026-44741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44741
- OSV: https://osv.dev/vulnerability/CVE-2026-44741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44741/
Summaries are generated and may contain mistakes; the official description above is the record.
