{"answers":{"affected":"3 open source packages ship an affected version, including postorius. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44742 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-44742 is a high-severity cross-site scripting vulnerability in Postorius, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44742 and fix it if it is affected.\n\nWhat it is: CVE-2026-44742 is a high-severity cross-site scripting vulnerability in Postorius, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44742 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postorius (PyPI): affected all versions up to 1.3.13; no fix listed\n- postorius (PyPI): affected all versions up to 1.3.13; no fix listed\n- postorius (PyPI): affected all versions up to 1.3.13; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44742/ (Markdown: https://insights.sbomify.com/CVE-2026-44742/index.md)","id":"CVE-2026-44742","markdown":"https://insights.sbomify.com/CVE-2026-44742/index.md","name":"CVE-2026-44742","record":{"aliases":["DEBIAN-CVE-2026-44742","GHSA-r7c9-7pjq-hmm8","PYSEC-2026-2891","UBUNTU-CVE-2026-44742","USN-8323-1","openSUSE-SU-2026:11539-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Postorius web interface","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in the Postorius held messages pop-up due to unescaped HTML in message subjects, potentially compromising user accounts.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"postorius","vendor":"postorius_project"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Postorius through 1.3.13 does not escape HTML in the message subject when rendering it in the Held messages pop-up, as exploited in the wild in May 2026.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Postorius is vulnerable to XSS","id":"CVE-2026-44742","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"Security Misconfiguration vulnerability in SAP Business Objects","id":"CVE-2026-44743"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.3.13"],"package":"postorius","purl":null,"source":"GHSA-r7c9-7pjq-hmm8"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.3.13"],"package":"postorius","purl":"pkg:pypi/postorius","source":"GHSA-r7c9-7pjq-hmm8"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.3.13"],"package":"postorius","purl":"pkg:pypi/postorius","source":"PYSEC-2026-2891"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.3.13-8.1"],"introduced":["0"],"last_affected":[],"package":"python-postorius","purl":"pkg:rpm/opensuse/python-postorius\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11539-1"}],"prev":{"headline":"Pimcore Admin Classic Bundle Vulnerable to SQL Injection in Translation Grid Date Filter via Unsanitized Property Parameter","id":"CVE-2026-44741"},"products":["Postorius"],"published":"2026-05-07","related":[{"cvss_score":5.4,"headline":"GNU Mailman Postorius Access Control Issues","id":"CVE-2021-40347","kev_date_added":null,"published":"2021-09-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-25","vendors":["Postorius project"]},"summary":"Attackers can execute arbitrary scripts in the Postorius held messages pop-up due to unescaped HTML in message subjects, potentially compromising user accounts.","url":"https://insights.sbomify.com/CVE-2026-44742/"}