CVE-2026-44778 Inspektor Gadget: Unprivileged container can crash USDT note parser via crafted ELF

Low 2.9 Published Updated

An unprivileged container can crash the privileged Inspektor Gadget process via a crafted ELF binary when using custom USDT gadgets.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44778?

CVE-2026-44778 is a low-severity denial of service vulnerability in inspektor-gadget, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Inspektor Gadget is a set of tools and framework for data collection and system inspection on Kubernetes clusters and Linux hosts using eBPF. From 0.28.0 until 0.53.1, the USDT note parser in pkg/uprobetracer/usdt.go can allow an unprivileged container to crash or exhaust the memory of the privileged Inspektor Gadget process when a custom gadget containing a SEC("usdt/...") eBPF section attaches to a crafted ELF binary. The getUsdtInfo() function reads the .note.stapsdt section without validating that DescSize is large enough for three address fields, allowing an out-of-bounds slice operation to panic, and it uses untrusted NameSize and DescSize values for allocations that can consume gigabytes of memory. The parser also invokes debug/elf without panic recovery, allowing other malformed ELF structures to terminate the process. No gadget shipped by Inspektor Gadget uses USDT probes, so only deployments using custom USDT gadgets are affected, and the demonstrated impact is denial of service rather than code execution or privilege escalation. This issue is fixed in version 0.53.1.

Weakness: CWE-20

Which versions are affected by CVE-2026-44778?

3 open source packages ship an affected version, including github.com/inspektor-gadget/inspektor-gadget.

PackageAffectedFixed in
github.com/inspektor-gadget/inspektor-gadget GoFrom 0.28.00.53.1
github.com/inspektor-gadget/inspektor-gadget GoFrom 0.28.00.53.1
github.com/inspektor-gadget/inspektor-gadget GoFrom 0.28.00.53.1

How do I fix CVE-2026-44778?

Upgrade github.com/inspektor-gadget/inspektor-gadget to 0.53.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-44778 being exploited?

There is no known exploitation of CVE-2026-44778 in the wild and no public exploit code.

Sources

Also known as GHSA-7cfq-5mhv-jrp9, GO-2026-5214.

Is CVE-2026-44778 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free