CVE-2026-44783 Discourse: Replying to a whisper lets non-whisperers create staff-only whisper posts
Authenticated users can bypass restrictions to post in staff-only whisper channels if whispers are enabled, allowing unauthorized content injection.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44783?
CVE-2026-44783 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.4, 2026.3.0-latest to before 2026.3.1, and 2026.4.0-latest to before 2026.4.1, a flaw in how replies to whisper posts are handled allows authenticated users outside the groups configured in whispers_allowed_groups to post into a topic's staff-only whisper channel. The injected content is visible to whisperers (typically staff) alongside legitimate whispers. Only sites that have whispers enabled are affected. This issue has been patched in versions 2026.1.4, 2026.3.1, 2026.4.1, and 2026.5.0-latest.1.
Weakness: CWE-284
Which versions are affected by CVE-2026-44783?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | From 2026.1.0 | 2026.1.4, 2026.3.1, 2026.4.1 |
Products include Discourse Discourse.
How do I fix CVE-2026-44783?
Upgrade discourse to a fixed version for your release line: 2026.1.4, 2026.3.1 or 2026.4.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-44783 being exploited?
There is no known exploitation of CVE-2026-44783 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-44783, GHSA-98ch-mgfj-wqpw.