CVE-2026-44787 Discourse: Signup-time primary_group_id assignment grants whisperer access

High 8.2 Published Updated

New users can gain whisper-group privileges by setting primary_group_id during signup on sites with specific group configurations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44787?

CVE-2026-44787 is a high-severity vulnerability in Discourse Discourse, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, the signup flow could allow newly registered users to set primary_group_id and gain whisper-group privileges without legitimate group membership on sites with whispers_allowed_groups configured. This issue is fixed in versions 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.

Weakness: CWE-269

Which versions are affected by CVE-2026-44787?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.5, 2026.4.2, 2026.5.1

Products include Discourse Discourse.

How do I fix CVE-2026-44787?

Upgrade discourse to a fixed version for your release line: 2026.1.5, 2026.4.2 or 2026.5.1.

Is CVE-2026-44787 being exploited?

There is no known exploitation of CVE-2026-44787 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-44787, GHSA-vmwq-jvxx-jwfx.

Is CVE-2026-44787 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free