# CVE-2026-44787: Discourse: Signup-time primary_group_id assignment grants whisperer access

> New users can gain whisper-group privileges by setting primary_group_id during signup on sites with specific group configurations.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** BIT-discourse-2026-44787, GHSA-vmwq-jvxx-jwfx

## What is CVE-2026-44787?

CVE-2026-44787 is a high-severity vulnerability in Discourse Discourse, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, the signup flow could allow newly registered users to set primary_group_id and gain whisper-group privileges without legitimate group membership on sites with whispers_allowed_groups configured. This issue is fixed in versions 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-44787?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | From 2026.1.0 | 2026.1.5, 2026.4.2, 2026.5.1 |

Products: Discourse Discourse.

## How do I fix CVE-2026-44787?

Upgrade discourse to a fixed version for your release line: 2026.1.5, 2026.4.2 or 2026.5.1.

## Is CVE-2026-44787 being exploited?

There is no known exploitation of CVE-2026-44787 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44787 and fix it if it is affected.

What it is: CVE-2026-44787 is a high-severity vulnerability in Discourse Discourse, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44787 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected from 2026.1.0; fixed in 2026.1.5, 2026.4.2, 2026.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44787/ (Markdown: https://insights.sbomify.com/CVE-2026-44787/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44787
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44787
- OSV: https://osv.dev/vulnerability/CVE-2026-44787

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44787/
Summaries are generated and may contain mistakes; the official description above is the record.
