CVE-2026-44795 Spinnaker: Non-safe yaml deserialization allowing RCE when using specific types
Attackers can achieve remote code execution in Spinnaker by exploiting unsafe YAML deserialization during CloudFormation or CloudFoundry deployments.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44795?
CVE-2026-44795 is a high-severity unsafe deserialization vulnerability in spinnaker, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Spinnaker is an open source, multi-cloud continuous delivery platform. Prior to 2026.1.0, 2026.0.3, 2025.4.4, and 2025.3.3, unsafe YAML processing bypasses safe deserialization when using CloudFormation deployments or CloudFoundry baking. The use of a non-safe constructor allows arbitrary loading of Java classes, leading to remote code execution. This issue is fixed in versions 2026.1.0, 2026.0.3, 2025.4.4, and 2025.3.3.
Which versions are affected by CVE-2026-44795?
12 open source packages ship an affected version, including io.spinnaker.orca:orca-core and io.spinnaker.rosco:rosco-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.spinnaker.orca:orca-core Maven | All versions | 2025.3.3 |
io.spinnaker.orca:orca-core Maven | All versions | 2025.3.3 |
io.spinnaker.orca:orca-core Maven | From 2025.4.0 | 2025.4.4 |
io.spinnaker.orca:orca-core Maven | From 2025.4.0 | 2025.4.4 |
io.spinnaker.orca:orca-core Maven | From 2026.0.0 | 2026.0.3 |
io.spinnaker.orca:orca-core Maven | From 2026.0.0 | 2026.0.3 |
6 more packages
io.spinnaker.rosco:rosco-core Maven | All versions | 2025.3.3 |
io.spinnaker.rosco:rosco-core Maven | All versions | 2025.3.3 |
io.spinnaker.rosco:rosco-core Maven | From 2025.4.0 | 2025.4.4 |
io.spinnaker.rosco:rosco-core Maven | From 2025.4.0 | 2025.4.4 |
io.spinnaker.rosco:rosco-core Maven | From 2026.0.0 | 2026.0.3 |
io.spinnaker.rosco:rosco-core Maven | From 2026.0.0 | 2026.0.3 |
Products include Linuxfoundation Spinnaker.
How do I fix CVE-2026-44795?
Upgrade io.spinnaker.orca:orca-core to a fixed version for your release line: 2025.3.3, 2025.4.4 or 2026.0.3.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-44795 being exploited?
There is no known exploitation of CVE-2026-44795 in the wild and no public exploit code.
Other vulnerabilities in spinnaker
- CVE-2026-32604 Spinnaker: RCE when using gitrepo artifact types due to improper sanitization of user input on branch and paths
- CVE-2026-32613 Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling
- CVE-2021-43832 Improper Access Control in spinnaker
- CVE-2020-9301 Code injection in Netflix Spinnaker
- CVE-2025-61916 Spinnaker vulnerable to SSRF due to improper restrictions on http from user input
Sources
Also known as GHSA-c8q4-9h32-2ww8.