# CVE-2026-44798: Nautobot: GitRepository.current_head field should not be writable through REST API

> Attackers with repository access can manipulate Git HEAD pointers via API, causing misleading states or service disruption in Nautobot.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-p3hx-pwf3-j8wr, PYSEC-2026-2228

## What is CVE-2026-44798?

CVE-2026-44798 is a high-severity missing authorization vulnerability in nautobot, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nautobot is a Network Source of Truth and Network Automation Platform. Prior to 2.4.33 and 3.1.2, a user with access to add/change a GitRepository record could use the REST API to directly set the current_head field on the record, which was not intended to be user-editable. Doing so could cause Nautobot's local clone(s) of the relevant repository to checkout a commit other than the latest commit on the specified branch (resulting in misleading state), or potentially to be unable to make use of the repository at all (until manually remediated) due to the current_head pointing to a nonexistent commit hash or malformed value. This vulnerability is fixed in 2.4.33 and 3.1.2.

Weakness: CWE-749 (Exposed Dangerous Method or Function), CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2026-44798?

5 open source packages ship an affected version, including nautobot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nautobot` | PyPI | All versions | 2.4.33, 3.1.2 |
| `nautobot` | PyPI | All versions | 2.4.33 |
| `nautobot` | PyPI | All versions | 2.4.33 |
| `nautobot` | PyPI | From 3.0.0a2 | 3.1.2 |
| `nautobot` | PyPI | From 3.0.0a2 | 3.1.2 |

Products: Networktocode Nautobot.

## How do I fix CVE-2026-44798?

Upgrade nautobot to a fixed version for your release line: 2.4.33 or 3.1.2.

## Is CVE-2026-44798 being exploited?

There is no known exploitation of CVE-2026-44798 in the wild and no public exploit code.

## Other vulnerabilities in nautobot

- [CVE-2026-44797](https://insights.sbomify.com/CVE-2026-44797/): Nautobot: Webhook definitions could be used for server-side request forgery (SSRF) (high 8.5)
- [CVE-2024-34707](https://insights.sbomify.com/CVE-2024-34707/): Nautobot's BANNER_* configuration can be used to inject arbitrary HTML content into Nautobot pages (high 7.5)
- [CVE-2024-32979](https://insights.sbomify.com/CVE-2024-32979/): Reflected Cross-site Scripting potential in all object list views in Nautobot (high 7.5)
- [CVE-2023-25657](https://insights.sbomify.com/CVE-2023-25657/): Remote code execution in Jinja2 template rendering in Nautobot (high 7.5)
- [CVE-2024-23345](https://insights.sbomify.com/CVE-2024-23345/): Nautobot has XSS potential in rendered Markdown fields (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44798 and fix it if it is affected.

What it is: CVE-2026-44798 is a high-severity missing authorization vulnerability in nautobot, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44798 in the wild and no public exploit code.

Affected packages and fixed versions:
- nautobot (PyPI): affected all versions; fixed in 2.4.33, 3.1.2
- nautobot (PyPI): affected all versions; fixed in 2.4.33
- nautobot (PyPI): affected all versions; fixed in 2.4.33
- nautobot (PyPI): affected from 3.0.0a2; fixed in 3.1.2
- nautobot (PyPI): affected from 3.0.0a2; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44798/ (Markdown: https://insights.sbomify.com/CVE-2026-44798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44798
- OSV: https://osv.dev/vulnerability/CVE-2026-44798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44798/
Summaries are generated and may contain mistakes; the official description above is the record.
