# CVE-2026-44825: Apache Solr: Enabling BasicAuth using bin/solr CLI configures additional insecure users

> Remote attackers can gain full administrative access to Apache Solr clusters using hardcoded default credentials created by the BasicAuth setup tool.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-solr-2026-44825, CLEANSTART-2026-MT16431, GHSA-qhr7-h655-pw6r, MINI-8gm8-24vv-95c9

## What is CVE-2026-44825?

CVE-2026-44825 is a high-severity vulnerability in Apache Solr, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hardcoded credentials in the Basic Authentication setup tool (bin/solr auth enable) in Apache Solr versions 9.4.0 through 9.10.1 and 10.0.0 allows a remote attacker to gain full administrative access to the cluster via publicly known default credentials installed silently alongside the user-specified account. 

As an immediate workaround without upgrading, delete the template users (superadmin, admin, search, index) from security.json or change their passwords.
The future, not yet released, versions 9.11.0 and 10.1.0 will not be vulnerable, and it will be enough to upgrade to solve the issue.

Not affected:
  *  Clusters where bin/solr auth enable was not used to bootstrap BasicAuth
  *  Clusters where template users have been assigned strong passwords after bootstrap

Weakness: CWE-798 (Use of Hard-coded Credentials), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-44825?

5 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | All versions | None |
| `org.apache.solr:solr-core` | Maven | All versions | None |
| `org.apache.solr:solr-core` | Maven | From 9.4.0 to 9.10.1 | None |
| `org.apache.solr:solr-core` | Maven | From 9.4.0 to 9.10.1 | None |
| `solr` | Bitnami | From 9.4.0 to 10.0.0 | 10.0.0 |

Products: Apache Solr.

## How do I fix CVE-2026-44825?

Upgrade to a fixed version.

## Is CVE-2026-44825 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44825 exists.

Public exploit code:

- Apache Solr instances that may be affected by CVE-2026-44825, related to Velocity Template Remote Code Execution (RCE) conditions. (github_poc): https://github.com/gagaltotal/CVE-2026-44825-Apache-Solr-Scanner
- ☄️ Mass reconnaissance & exploitation framework for Apache Solr CVE-2026-44825 — Velocity template injection to RCE (github_poc): https://github.com/shinthink/solrradar
- https://github.com/q0524/CVE-2026-44825_CTF (github_poc): https://github.com/q0524/CVE-2026-44825_CTF
- Apache Solr 9.4.0-9.10.1 / 10.0.0 - Hardcoded Default Credentials (nuclei): http/cves/2026/CVE-2026-44825.yaml

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44825 and fix it if it is affected.

What it is: CVE-2026-44825 is a high-severity vulnerability in Apache Solr, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44825 exists.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected all versions; no fix listed
- org.apache.solr:solr-core (Maven): affected all versions; no fix listed
- org.apache.solr:solr-core (Maven): affected from 9.4.0 up to 9.10.1; no fix listed
- org.apache.solr:solr-core (Maven): affected from 9.4.0 up to 9.10.1; no fix listed
- solr (Bitnami): affected from 9.4.0 up to 10.0.0; fixed in 10.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44825/ (Markdown: https://insights.sbomify.com/CVE-2026-44825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44825
- OSV: https://osv.dev/vulnerability/CVE-2026-44825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44825/
Summaries are generated and may contain mistakes; the official description above is the record.
