CVE-2026-44827 Diffusers: None.py Trust Remote Code Bypass

High 8.8 Published Updated

Attackers can execute arbitrary code by publishing a malicious None.py file in a Hugging Face repository, bypassing trust_remote_code safeguards in Diffusers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-44827?

CVE-2026-44827 is a high-severity code injection vulnerability in huggingface diffusers, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Diffusers is the a library for pretrained diffusion models. Prior to 0.38.0, diffusers 0.37.0 allows remote code execution without the trust_remote_code=True safeguard when loading pipelines from Hugging Face Hub repositories. The _resolve_custom_pipeline_and_cls function in pipeline_loading_utils.py performs string interpolation on the custom_pipeline parameter using f"{custom_pipeline}.py". When custom_pipeline is not supplied by the user, it defaults to None, which Python interpolates as the literal string "None.py". If an attacker publishes a Hub repository containing a file named None.py with a class that subclasses DiffusionPipeline, the file is automatically downloaded and executed during a standard DiffusionPipeline.from_pretrained() call with no additional keyword arguments. The trust_remote_code check in DiffusionPipeline.download() is bypassed because it evaluates custom_pipeline is not None as False (since the kwarg was never supplied), while the downstream code path that actually loads the module resolves the None value into a valid filename. An attacker can achieve silent arbitrary code execution by publishing a malicious model repository with a None.py file and a standard-looking model_index.json that references a legitimate pipeline class name, requiring only that a victim calls from_pretrained on the repository. This vulnerability is fixed in 0.38.0.

Weakness: CWE-94

Which versions are affected by CVE-2026-44827?

3 open source packages ship an affected version, including diffusers. It affects 1 product.

PackageAffectedFixed in
diffusers PyPIAll versions0.38.0
diffusers PyPIAll versions0.38.0
diffusers PyPIAll versions0.38.0

Products include Huggingface Diffusers.

How do I fix CVE-2026-44827?

Upgrade diffusers to 0.38.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-44827 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44827 exists.

Sources

Also known as GHSA-j7w6-vpvq-j3gm, PYSEC-2026-41.

Is CVE-2026-44827 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free