# CVE-2026-44827: Diffusers: None.py Trust Remote Code Bypass

> Attackers can execute arbitrary code by publishing a malicious None.py file in a Hugging Face repository, bypassing trust_remote_code safeguards in Diffusers.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-j7w6-vpvq-j3gm, PYSEC-2026-41

## What is CVE-2026-44827?

CVE-2026-44827 is a high-severity code injection vulnerability in huggingface diffusers, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Diffusers is the a library for  pretrained diffusion models. Prior to 0.38.0, diffusers 0.37.0 allows remote code execution without the trust_remote_code=True safeguard when loading pipelines from Hugging Face Hub repositories. The _resolve_custom_pipeline_and_cls function in pipeline_loading_utils.py performs string interpolation on the custom_pipeline parameter using f"{custom_pipeline}.py". When custom_pipeline is not supplied by the user, it defaults to None, which Python interpolates as the literal string "None.py". If an attacker publishes a Hub repository containing a file named None.py with a class that subclasses DiffusionPipeline, the file is automatically downloaded and executed during a standard DiffusionPipeline.from_pretrained() call with no additional keyword arguments. The trust_remote_code check in DiffusionPipeline.download() is bypassed because it evaluates custom_pipeline is not None as False (since the kwarg was never supplied), while the downstream code path that actually loads the module resolves the None value into a valid filename. An attacker can achieve silent arbitrary code execution by publishing a malicious model repository with a None.py file and a standard-looking model_index.json that references a legitimate pipeline class name, requiring only that a victim calls from_pretrained on the repository. This vulnerability is fixed in 0.38.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-44827?

3 open source packages ship an affected version, including diffusers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `diffusers` | PyPI | All versions | 0.38.0 |
| `diffusers` | PyPI | All versions | 0.38.0 |
| `diffusers` | PyPI | All versions | 0.38.0 |

Products: Huggingface Diffusers.

## How do I fix CVE-2026-44827?

Upgrade diffusers to 0.38.0 or later.

## Is CVE-2026-44827 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44827 exists.

## Other vulnerabilities in huggingface diffusers

- [CVE-2026-44513](https://insights.sbomify.com/CVE-2026-44513/): Diffusers: `trust_remote_code` bypass via `custom_pipeline` and local custom components (high 8.8)
- [CVE-2026-45804](https://insights.sbomify.com/CVE-2026-45804/): Diffusers: TOCTOU Trust Remote Code Bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44827 and fix it if it is affected.

What it is: CVE-2026-44827 is a high-severity code injection vulnerability in huggingface diffusers, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44827 exists.

Affected packages and fixed versions:
- diffusers (PyPI): affected all versions; fixed in 0.38.0
- diffusers (PyPI): affected all versions; fixed in 0.38.0
- diffusers (PyPI): affected all versions; fixed in 0.38.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44827/ (Markdown: https://insights.sbomify.com/CVE-2026-44827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44827
- OSV: https://osv.dev/vulnerability/CVE-2026-44827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44827/
Summaries are generated and may contain mistakes; the official description above is the record.
