CVE-2026-44831 Snipe-IT: XSS vulnerability in component notes
Attackers can inject malicious scripts via unescaped component notes, potentially compromising user sessions in Snipe-IT.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-44831?
CVE-2026-44831 is a medium-severity cross-site scripting vulnerability in Snipeitapp Snipe-It, published on 26 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Snipe-IT is an IT asset/license management system. Prior to 8.4.1, users with component view access could be impacted by an unescaped notes column, resulting in cross-site scripting (XSS). This vulnerability is fixed in 8.4.1.
Weakness: CWE-79
Which versions are affected by CVE-2026-44831?
2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
snipe/snipe-it Packagist | All versions | 8.4.1 |
snipe/snipe-it Packagist | All versions | 8.4.1 |
Products include Snipeitapp Snipe-It.
How do I fix CVE-2026-44831?
Upgrade snipe/snipe-it to 8.4.1 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-44831 being exploited?
There is no known exploitation of CVE-2026-44831 in the wild and no public exploit code.
Other vulnerabilities in Snipeitapp Snipe-It
- CVE-2025-63601 File upload in n/a
- CVE-2026-37709 Snipe-IT has insecure permissions in file uploads
- CVE-2026-86738 Snipe-IT before 8.7.0 CSS Injection via Custom CSS
- CVE-2026-116199 Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback
- CVE-2022-1380 Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it
Sources
Also known as GHSA-r42m-953q-6vjx.