# CVE-2026-44836: view_component: Preview Route Can Dispatch Inherited Helper Methods

> Attackers can execute arbitrary code or read data by exploiting unsafe public_send calls in preview routes if previews are exposed.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2026
- **Updated:** 27 May 2026
- **Also known as:** DEBIAN-CVE-2026-44836, GHSA-7f3r-gwc9-2995, UBUNTU-CVE-2026-44836

## What is CVE-2026-44836?

CVE-2026-44836 is a medium-severity code injection vulnerability in ViewComponent view_component, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

view_component is a framework for building reusable, testable, and encapsulated view components in Ruby on Rails. From 3.0.0 to 4.9.0, the preview route derives an example name from the URL and calls it with public_send. The code does not verify that the requested method is one of the preview examples explicitly defined by the preview class. As a result, inherited public methods on ViewComponent::Preview are route-reachable. The most important one is render_with_template, which accepts template: and locals:. Those values can come from request params and are later passed to Rails as render template:. If previews are exposed, an attacker can render internal Rails templates that are not otherwise routable. This vulnerability is fixed in 4.9.0.

Weakness: CWE-749 (Exposed Dangerous Method or Function)

## Which versions are affected by CVE-2026-44836?

2 open source packages ship an affected version, including view_component.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `view_component` | RubyGems | From 3.0.0 | 4.9.0 |
| `view_component` | RubyGems | From 3.0.0 | 4.9.0 |

## How do I fix CVE-2026-44836?

Upgrade view_component to 4.9.0 or later.

## Is CVE-2026-44836 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44836 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44836 and fix it if it is affected.

What it is: CVE-2026-44836 is a medium-severity code injection vulnerability in ViewComponent view_component, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44836 exists.

Affected packages and fixed versions:
- view_component (RubyGems): affected from 3.0.0; fixed in 4.9.0
- view_component (RubyGems): affected from 3.0.0; fixed in 4.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44836/ (Markdown: https://insights.sbomify.com/CVE-2026-44836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44836
- OSV: https://osv.dev/vulnerability/CVE-2026-44836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44836/
Summaries are generated and may contain mistakes; the official description above is the record.
