CVE-2026-44838 RabbitMQ MQTT Topic Permission Authorization Bypass

Medium 5.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-44838?

CVE-2026-44838 is a medium-severity vulnerability in Broadcom Rabbitmq Server, published on 27 May 2026.

Official description

RabbitMQ is a messaging and streaming broker. From 4.2.0 to before 4.2.4, RabbitMQ's MQTT plugin allows for topic-level authorization using regular expressions with variable substitution. Administrators can create patterns such as ^{client_id}-sensors$ to restrict user access to topics that include their client ID. However, the client_id is provided by the user in the MQTT CONNECT packet and is inserted into the regex pattern without escaping special regex characters. This flaw enables an authenticated MQTT user to inject regex operators to bypass authorization. This vulnerability is fixed in 4.2.4 and 4.3.0.

Weakness: CWE-863

Which versions are affected by CVE-2026-44838?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.

PackageAffectedFixed in
rabbitmq BitnamiFrom 4.2.04.2.4
Linux distribution packages (2)
rabbitmq-server4.2 Red Hat:hummingbird:1All versions0:4.2.9-0.1.hum1
rabbitmq-server4.3 Red Hat:hummingbird:1All versions0:4.3.4-0.1.hum1

Products include Broadcom Rabbitmq Server.

How do I fix CVE-2026-44838?

Upgrade rabbitmq to 4.2.4 or later.

Is CVE-2026-44838 being exploited?

There is no known exploitation of CVE-2026-44838 in the wild and no public exploit code.

All Broadcom Rabbitmq Server vulnerabilities

Sources

Also known as BIT-rabbitmq-2026-44838, GHSA-x866-xp2g-cx8v, RHSA-2026:42387, RHSA-2026:45128.

Is CVE-2026-44838 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free