# CVE-2026-44838: RabbitMQ MQTT Topic Permission Authorization Bypass


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** BIT-rabbitmq-2026-44838, GHSA-x866-xp2g-cx8v, RHSA-2026:42387, RHSA-2026:45128

## What is CVE-2026-44838?

CVE-2026-44838 is a medium-severity vulnerability in Broadcom Rabbitmq Server, published on 27 May 2026. 

### Official description

RabbitMQ is a messaging and streaming broker. From 4.2.0 to before 4.2.4, RabbitMQ's MQTT plugin allows for topic-level authorization using regular expressions with variable substitution. Administrators can create patterns such as ^{client_id}-sensors$ to restrict user access to topics that include their client ID. However, the client_id is provided by the user in the MQTT CONNECT packet and is inserted into the regex pattern without escaping special regex characters. This flaw enables an authenticated MQTT user to inject regex operators to bypass authorization. This vulnerability is fixed in 4.2.4 and 4.3.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-44838?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 4.2.0 | 4.2.4 |
| `rabbitmq-server4.2` | Red Hat:hummingbird:1 | All versions | 0:4.2.9-0.1.hum1 |
| `rabbitmq-server4.3` | Red Hat:hummingbird:1 | All versions | 0:4.3.4-0.1.hum1 |

Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-44838?

Upgrade rabbitmq to 4.2.4 or later.

## Is CVE-2026-44838 being exploited?

There is no known exploitation of CVE-2026-44838 in the wild and no public exploit code.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44838 and fix it if it is affected.

What it is: CVE-2026-44838 is a medium-severity vulnerability in Broadcom Rabbitmq Server, published on 27 May 2026. 
Exploitation: There is no known exploitation of CVE-2026-44838 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 4.2.0; fixed in 4.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44838/ (Markdown: https://insights.sbomify.com/CVE-2026-44838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44838
- OSV: https://osv.dev/vulnerability/CVE-2026-44838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44838/
Summaries are generated and may contain mistakes; the official description above is the record.
