CVE-2026-44843 LangChain: Unsafe deserialization of attacker-controlled LangChain objects through overly broad `load()` allowlists
Attackers can instantiate trusted LangChain classes with untrusted arguments via overly broad deserialization allowlists, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44843?
CVE-2026-44843 is a high-severity unsafe deserialization vulnerability in langchain-ai langchain, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
LangChain is a framework for building agents and LLM-powered applications. Prior to 0.3.85 and 1.3.3, LangChain contains older runtime code paths that deserialize run inputs, run outputs, or other application-controlled payloads using overly broad object allowlists. These paths may call load() with allowed_objects="all". This does not enable arbitrary Python object deserialization, but it does allow any trusted LangChain-serializable object to be revived, which is broader than these runtime paths require. As a result, attacker-supplied LangChain serialized constructor dictionaries may cause trusted runtime paths to instantiate classes with untrusted constructor arguments. This vulnerability is fixed in 0.3.85 and 1.3.3.
Weakness: CWE-502
Which versions are affected by CVE-2026-44843?
5 open source packages ship an affected version, including langchain-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
langchain-core PyPI | All versions | 0.3.85, 1.3.3 |
langchain-core PyPI | All versions | 0.3.85 |
langchain-core PyPI | All versions | 0.3.85 |
langchain-core PyPI | From 1.0.0 | 1.3.3 |
langchain-core PyPI | From 1.0.0 | 1.3.3 |
Products include Langchain Langchain.
How do I fix CVE-2026-44843?
Upgrade langchain-core to a fixed version for your release line: 0.3.85 or 1.3.3.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-44843 being exploited?
There is no known exploitation of CVE-2026-44843 in the wild and no public exploit code.
Other vulnerabilities in langchain-ai langchain
- CVE-2023-39631 Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library
- CVE-2023-36281 langchain vulnerable to arbitrary code execution
- CVE-2023-38860 LangChain vulnerable to arbitrary code execution
- CVE-2023-38896 LangChain vulnerable to arbitrary code execution
- CVE-2023-39659 LangChain vulnerable to arbitrary code execution
Sources
Also known as CLSA-2026-1781571263, ECHO-6a00-8440-c5ae, GHSA-pjwx-r37v-7724, PYSEC-2026-2564, ROOT-APP-PYPI-CVE-2026-44843.