{"answers":{"affected":"5 open source packages ship an affected version, including langchain-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44843 in the wild and no public exploit code.","fix":"Upgrade langchain-core to a fixed version for your release line: 0.3.85 or 1.3.3.","what":"CVE-2026-44843 is a high-severity unsafe deserialization vulnerability in langchain-ai langchain, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44843 and fix it if it is affected.\n\nWhat it is: CVE-2026-44843 is a high-severity unsafe deserialization vulnerability in langchain-ai langchain, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44843 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- langchain-core (PyPI): affected all versions; fixed in 0.3.85, 1.3.3\n- langchain-core (PyPI): affected all versions; fixed in 0.3.85\n- langchain-core (PyPI): affected all versions; fixed in 0.3.85\n- langchain-core (PyPI): affected from 1.0.0; fixed in 1.3.3\n- langchain-core (PyPI): affected from 1.0.0; fixed in 1.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44843/ (Markdown: https://insights.sbomify.com/CVE-2026-44843/index.md)","id":"CVE-2026-44843","markdown":"https://insights.sbomify.com/CVE-2026-44843/index.md","name":"CVE-2026-44843","record":{"aliases":["CLSA-2026-1781571263","ECHO-6a00-8440-c5ae","GHSA-pjwx-r37v-7724","PYSEC-2026-2564","ROOT-APP-PYPI-CVE-2026-44843"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LangChain framework","requires_auth":"none","summary":"Attackers can instantiate trusted LangChain classes with untrusted arguments via overly broad deserialization allowlists, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"langchain","vendor":"langchain"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"LangChain is a framework for building agents and LLM-powered applications. Prior to 0.3.85 and 1.3.3, LangChain contains older runtime code paths that deserialize run inputs, run outputs, or other application-controlled payloads using overly broad object allowlists. These paths may call load() with allowed_objects=\"all\". This does not enable arbitrary Python object deserialization, but it does allow any trusted LangChain-serializable object to be revived, which is broader than these runtime paths require. As a result, attacker-supplied LangChain serialized constructor dictionaries may cause trusted runtime paths to instantiate classes with untrusted constructor arguments. This vulnerability is fixed in 0.3.85 and 1.3.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LangChain: Unsafe deserialization of attacker-controlled LangChain objects through overly broad `load()` allowlists","id":"CVE-2026-44843","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":5,"n_references":1,"next":{"headline":"eml_parser: Recursion DoS via nested message/rfc822 attachments","id":"CVE-2026-44844"},"packages":[{"ecosystem":"PyPI","fixed":["0.3.85","1.3.3"],"introduced":["0","1.0.0"],"last_affected":[],"package":"langchain-core","purl":"pkg:pypi/langchain-core","source":"PYSEC-2026-2564"},{"ecosystem":"PyPI","fixed":["0.3.85"],"introduced":["0"],"last_affected":[],"package":"langchain-core","purl":null,"source":"GHSA-pjwx-r37v-7724"},{"ecosystem":"PyPI","fixed":["0.3.85"],"introduced":["0"],"last_affected":[],"package":"langchain-core","purl":"pkg:pypi/langchain-core","source":"GHSA-pjwx-r37v-7724"},{"ecosystem":"PyPI","fixed":["1.3.3"],"introduced":["1.0.0"],"last_affected":[],"package":"langchain-core","purl":null,"source":"GHSA-pjwx-r37v-7724"},{"ecosystem":"PyPI","fixed":["1.3.3"],"introduced":["1.0.0"],"last_affected":[],"package":"langchain-core","purl":"pkg:pypi/langchain-core","source":"GHSA-pjwx-r37v-7724"}],"prev":{"headline":"Dgraph Vulnerable to DQL Injection via checkUserPassword GraphQL Query","id":"CVE-2026-44840"},"products":["langchain"],"published":"2026-05-26","related":[{"cvss_score":9.8,"headline":"Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library","id":"CVE-2023-39631","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36281","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38860","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38896","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-39659","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"langchain Code Injection vulnerability","id":"CVE-2023-36095","kev_date_added":null,"published":"2023-08-05"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36188","kev_date_added":null,"published":"2023-07-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-27","vendors":["langchain-ai"]},"summary":"Attackers can instantiate trusted LangChain classes with untrusted arguments via overly broad deserialization allowlists, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-44843/"}