# CVE-2026-44843: LangChain: Unsafe deserialization of attacker-controlled LangChain objects through overly broad `load()` allowlists

> Attackers can instantiate trusted LangChain classes with untrusted arguments via overly broad deserialization allowlists, potentially leading to code execution.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2026
- **Updated:** 27 May 2026
- **Also known as:** CLSA-2026-1781571263, ECHO-6a00-8440-c5ae, GHSA-pjwx-r37v-7724, PYSEC-2026-2564, ROOT-APP-PYPI-CVE-2026-44843

## What is CVE-2026-44843?

CVE-2026-44843 is a high-severity unsafe deserialization vulnerability in langchain-ai langchain, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LangChain is a framework for building agents and LLM-powered applications. Prior to 0.3.85 and 1.3.3, LangChain contains older runtime code paths that deserialize run inputs, run outputs, or other application-controlled payloads using overly broad object allowlists. These paths may call load() with allowed_objects="all". This does not enable arbitrary Python object deserialization, but it does allow any trusted LangChain-serializable object to be revived, which is broader than these runtime paths require. As a result, attacker-supplied LangChain serialized constructor dictionaries may cause trusted runtime paths to instantiate classes with untrusted constructor arguments. This vulnerability is fixed in 0.3.85 and 1.3.3.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-44843?

5 open source packages ship an affected version, including langchain-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain-core` | PyPI | All versions | 0.3.85, 1.3.3 |
| `langchain-core` | PyPI | All versions | 0.3.85 |
| `langchain-core` | PyPI | All versions | 0.3.85 |
| `langchain-core` | PyPI | From 1.0.0 | 1.3.3 |
| `langchain-core` | PyPI | From 1.0.0 | 1.3.3 |

Products: Langchain Langchain.

## How do I fix CVE-2026-44843?

Upgrade langchain-core to a fixed version for your release line: 0.3.85 or 1.3.3.

## Is CVE-2026-44843 being exploited?

There is no known exploitation of CVE-2026-44843 in the wild and no public exploit code.

## Other vulnerabilities in langchain-ai langchain

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44843 and fix it if it is affected.

What it is: CVE-2026-44843 is a high-severity unsafe deserialization vulnerability in langchain-ai langchain, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44843 in the wild and no public exploit code.

Affected packages and fixed versions:
- langchain-core (PyPI): affected all versions; fixed in 0.3.85, 1.3.3
- langchain-core (PyPI): affected all versions; fixed in 0.3.85
- langchain-core (PyPI): affected all versions; fixed in 0.3.85
- langchain-core (PyPI): affected from 1.0.0; fixed in 1.3.3
- langchain-core (PyPI): affected from 1.0.0; fixed in 1.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44843/ (Markdown: https://insights.sbomify.com/CVE-2026-44843/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44843
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44843
- OSV: https://osv.dev/vulnerability/CVE-2026-44843

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44843/
Summaries are generated and may contain mistakes; the official description above is the record.
