{"answers":{"affected":"3 open source packages ship an affected version, including eml_parser and eml-parser.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44844 exists.","fix":"Upgrade eml_parser to 3.0.1 or later.","what":"CVE-2026-44844 is a medium-severity denial of service vulnerability in GOVCERT-LU eml_parser, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44844 and fix it if it is affected.\n\nWhat it is: CVE-2026-44844 is a medium-severity denial of service vulnerability in GOVCERT-LU eml_parser, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44844 exists.\n\nAffected packages and fixed versions:\n- eml_parser (PyPI): affected all versions; fixed in 3.0.1\n- eml-parser (PyPI): affected all versions; fixed in 3.0.1\n- eml-parser (PyPI): affected all versions; fixed in 3.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44844/ (Markdown: https://insights.sbomify.com/CVE-2026-44844/index.md)","id":"CVE-2026-44844","markdown":"https://insights.sbomify.com/CVE-2026-44844/index.md","name":"CVE-2026-44844","record":{"aliases":["GHSA-g47v-rwmh-r9f8","PYSEC-2026-2468"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python EML parser","requires_auth":"none","summary":"Attackers can crash the eml_parser library by supplying deeply nested EML files, causing a denial of service in applications using the parser.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"eml_parser serves as a python module for parsing eml files and returning various information found in the e-mail as well as computed information. Prior to 3.0.1, EmlParser.get_raw_body_text() recurses unconditionally for every nested message/rfc822 attachment without any depth limit. An attacker who can supply a badly crafted EML file with approximately 120 nested message/rfc822 parts triggers an unhandled RecursionError and aborts parsing of the message. A 12 KB EML file is enough to crash a worker. Though this causes the parser to crash, it is an unlikely scenario as the suggested EML that crashes the parser would not pass basic RFC compliance tests. This vulnerability is fixed in 3.0.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"eml_parser: Recursion DoS via nested message/rfc822 attachments","id":"CVE-2026-44844","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"JumpServer: Remote Command Execution (RCE) via Jinja Template Injection in Applet Host Deployment","id":"CVE-2026-44845"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"eml-parser","purl":"pkg:pypi/eml-parser","source":"GHSA-g47v-rwmh-r9f8"},{"ecosystem":"PyPI","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"eml-parser","purl":"pkg:pypi/eml-parser","source":"PYSEC-2026-2468"},{"ecosystem":"PyPI","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"eml_parser","purl":null,"source":"GHSA-g47v-rwmh-r9f8"}],"prev":{"headline":"LangChain: Unsafe deserialization of attacker-controlled LangChain objects through overly broad `load()` allowlists","id":"CVE-2026-44843"},"products":["eml_parser"],"published":"2026-05-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-27","vendors":["GOVCERT-LU"]},"summary":"Attackers can crash the eml_parser library by supplying deeply nested EML files, causing a denial of service in applications using the parser.","url":"https://insights.sbomify.com/CVE-2026-44844/"}