CVE-2026-44848 Portainer: Missing authorization on Docker plugin endpoints allows host RCE
Standard users can install Docker plugins via unsecured endpoints, leading to remote code execution on the host.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44848?
CVE-2026-44848 is a critical missing authorization vulnerability in portainer, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, The Docker plugin management endpoints (/plugins/*) were not registered with a handler, so standard users with endpoint access could call privileged plugin operations — including installing and enabling plugins — directly against the underlying Docker daemon. The vulnerability is exposed when a non-admin Portainer user (Standard User role, or any role granted endpoint-level access) has been given access to a Docker endpoint via Portainer RBAC. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.
Weakness: CWE-862
Which versions are affected by CVE-2026-44848?
7 open source packages ship an affected version, including github.com/portainer/portainer. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/portainer/portainer Go | All versions | None |
github.com/portainer/portainer Go | From 2.33.0 | 2.33.8 |
github.com/portainer/portainer Go | From 2.33.0 | 2.33.8 |
github.com/portainer/portainer Go | From 2.39.0 | 2.39.2 |
github.com/portainer/portainer Go | From 2.39.0 | 2.39.2 |
github.com/portainer/portainer Go | From 2.40.0 | 2.41.0 |
1 more packages
github.com/portainer/portainer Go | From 2.40.0 | 2.41.0 |
Products include Portainer Portainer.
How do I fix CVE-2026-44848?
Upgrade github.com/portainer/portainer to a fixed version for your release line: 2.33.8, 2.39.2 or 2.41.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-44848 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44848 exists.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in portainer
Sources
Also known as GHSA-rrmm-9v76-h3p4, GO-2026-5639.