# CVE-2026-44848: Portainer: Missing authorization on Docker plugin endpoints allows host RCE

> Standard users can install Docker plugins via unsecured endpoints, leading to remote code execution on the host.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-rrmm-9v76-h3p4, GO-2026-5639

## What is CVE-2026-44848?

CVE-2026-44848 is a critical missing authorization vulnerability in portainer, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, The Docker plugin management endpoints (/plugins/*) were not registered with a handler, so standard users with endpoint access could call privileged plugin operations — including installing and enabling plugins — directly against the underlying Docker daemon. The vulnerability is exposed when a non-admin Portainer user (Standard User role, or any role granted endpoint-level access) has been given access to a Docker endpoint via Portainer RBAC. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-44848?

7 open source packages ship an affected version, including github.com/portainer/portainer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/portainer/portainer` | Go | All versions | None |
| `github.com/portainer/portainer` | Go | From 2.33.0 | 2.33.8 |
| `github.com/portainer/portainer` | Go | From 2.33.0 | 2.33.8 |
| `github.com/portainer/portainer` | Go | From 2.39.0 | 2.39.2 |
| `github.com/portainer/portainer` | Go | From 2.39.0 | 2.39.2 |
| `github.com/portainer/portainer` | Go | From 2.40.0 | 2.41.0 |
| `github.com/portainer/portainer` | Go | From 2.40.0 | 2.41.0 |

Products: Portainer Portainer.

## How do I fix CVE-2026-44848?

Upgrade github.com/portainer/portainer to a fixed version for your release line: 2.33.8, 2.39.2 or 2.41.0.

## Is CVE-2026-44848 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44848 exists.

Public exploit code:

- PoC for CVE-2026-44848: Portainer missing authorization on Docker plugin endpoints -> host RCE (GHSA-rrmm-9v76-h3p4). Stdlib-only Python. (github_poc): https://github.com/Boreas37/CVE-2026-44848-PoC
- Non-destructive checker for CVE-2026-44848: Portainer missing authorization on Docker plugin endpoints (github_poc): https://github.com/mnk-works/portainer-cve-2026-44848-checker

## Other vulnerabilities in portainer

- [CVE-2019-16872](https://insights.sbomify.com/CVE-2019-16872/): Missing authorization in n/a (critical 9.9)
- [CVE-2022-24961](https://insights.sbomify.com/CVE-2022-24961/): Missing authorization in n/a (critical 9.8)
- [CVE-2020-24264](https://insights.sbomify.com/CVE-2020-24264/): Missing authorization in n/a (critical 9.8)
- [CVE-2018-19466](https://insights.sbomify.com/CVE-2018-19466/): Information disclosure in n/a (critical 9.8)
- [CVE-2018-19367](https://insights.sbomify.com/CVE-2018-19367/): Auth bypass in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44848 and fix it if it is affected.

What it is: CVE-2026-44848 is a critical missing authorization vulnerability in portainer, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44848 exists.

Affected packages and fixed versions:
- github.com/portainer/portainer (Go): affected all versions; no fix listed
- github.com/portainer/portainer (Go): affected from 2.33.0; fixed in 2.33.8
- github.com/portainer/portainer (Go): affected from 2.33.0; fixed in 2.33.8
- github.com/portainer/portainer (Go): affected from 2.39.0; fixed in 2.39.2
- github.com/portainer/portainer (Go): affected from 2.39.0; fixed in 2.39.2
- github.com/portainer/portainer (Go): affected from 2.40.0; fixed in 2.41.0
- github.com/portainer/portainer (Go): affected from 2.40.0; fixed in 2.41.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44848/ (Markdown: https://insights.sbomify.com/CVE-2026-44848/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44848
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44848
- OSV: https://osv.dev/vulnerability/CVE-2026-44848

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44848/
Summaries are generated and may contain mistakes; the official description above is the record.
