CVE-2026-44849 Portainer: Endpoint security bypass via Swarm service create/update
Attackers can bypass endpoint security restrictions on Docker Swarm services, allowing privileged container execution in Portainer.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44849?
CVE-2026-44849 is a critical vulnerability in portainer, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer enforces seven EndpointSecuritySettings restrictions that administrators configure to restrict the container configurations non-admin users can launch: privileged mode, host PID namespace, device mapping, capabilities, sysctls, security-opt (Seccomp / AppArmor), and bind mounts. These restrictions are enforced on the standard container creation path, but several of them are not applied on the Docker Swarm service API. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.
Weakness: CWE-862
Which versions are affected by CVE-2026-44849?
7 open source packages ship an affected version, including github.com/portainer/portainer. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/portainer/portainer Go | All versions | None |
github.com/portainer/portainer Go | From 2.33.0 | 2.33.8 |
github.com/portainer/portainer Go | From 2.33.0 | 2.33.8 |
github.com/portainer/portainer Go | From 2.39.0 | 2.39.2 |
github.com/portainer/portainer Go | From 2.39.0 | 2.39.2 |
github.com/portainer/portainer Go | From 2.40.0 | 2.41.0 |
1 more packages
github.com/portainer/portainer Go | From 2.40.0 | 2.41.0 |
Products include Portainer Portainer.
How do I fix CVE-2026-44849?
Upgrade github.com/portainer/portainer to a fixed version for your release line: 2.33.8, 2.39.2 or 2.41.0.
Is CVE-2026-44849 being exploited?
There is no known exploitation of CVE-2026-44849 in the wild and no public exploit code.
Other vulnerabilities in portainer
Sources
Also known as GHSA-5fxq-qcf3-244w, GO-2026-5143.