CVE-2026-44850 Portainer: Bind-mount restriction bypass via HostConfig.Mounts
Authenticated users can bypass bind-mount restrictions by using HostConfig.Mounts, allowing them to mount arbitrary host paths into containers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44850?
CVE-2026-44850 is a high-severity vulnerability in portainer, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer offers an environment-level Disable bind mounts for non-administrators security setting that blocks regular users from binding host paths into containers they create through the Portainer-mediated Docker API. The check that enforces this setting only inspected the legacy HostConfig.Binds array on the container-create proxy and never looked at the equivalent HostConfig.Mounts array. Any authenticated user with rights to create containers on a Docker environment where the restriction is enabled could submit a bind-typed entry under HostConfig.Mounts and mount any host path into their container. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.
Weakness: CWE-863
Which versions are affected by CVE-2026-44850?
7 open source packages ship an affected version, including github.com/portainer/portainer. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/portainer/portainer Go | All versions | None |
github.com/portainer/portainer Go | From 2.33.0 | 2.33.8 |
github.com/portainer/portainer Go | From 2.33.0 | 2.33.8 |
github.com/portainer/portainer Go | From 2.39.0 | 2.39.2 |
github.com/portainer/portainer Go | From 2.39.0 | 2.39.2 |
github.com/portainer/portainer Go | From 2.40.0 | 2.41.0 |
1 more packages
github.com/portainer/portainer Go | From 2.40.0 | 2.41.0 |
Products include Portainer Portainer.
How do I fix CVE-2026-44850?
Upgrade github.com/portainer/portainer to a fixed version for your release line: 2.33.8, 2.39.2 or 2.41.0.
Is CVE-2026-44850 being exploited?
There is no known exploitation of CVE-2026-44850 in the wild and no public exploit code.
Other vulnerabilities in portainer
Sources
Also known as GHSA-7fw3-x4r2-g7wc, GO-2026-5217.