CVE-2026-44882 Portainer: Kubernetes middleware continues after token validation failure, bypassing endpoint authorization
Attackers with valid sessions can bypass Kubernetes endpoint authorization checks due to a missing return statement in middleware, allowing unauthorized access to clusters.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44882?
CVE-2026-44882 is a high-severity missing authorization vulnerability in portainer, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33., Portainer proxies requests to Kubernetes clusters through a middleware layer (kubeClientMiddleware) that validates the requesting user's token before forwarding traffic to the cluster. When security.RetrieveTokenData returned an error, the middleware wrote an HTTP 403 response but was missing a return statement — execution continued into the handler with a nil tokenData value. The Kubernetes endpoints sit behind Portainer's outer AuthenticatedAccess bouncer, so an attacker requires a valid Portainer session. However, a user whose secondary token validation fails in kubeClientMiddleware — for example a user without permission to access a given Kubernetes endpoint — would have their request forwarded to the cluster anyway, bypassing the authorization check. The same defect was present in both the CE and EE codebases. This vulnerability is fixed in 2.33.8.
Weakness: CWE-863
Which versions are affected by CVE-2026-44882?
3 open source packages ship an affected version, including github.com/portainer/portainer. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/portainer/portainer Go | All versions | None |
github.com/portainer/portainer Go | From 2.33.0 | 2.33.8 |
github.com/portainer/portainer Go | From 2.33.0 | 2.33.8 |
Products include Portainer Portainer.
How do I fix CVE-2026-44882?
Upgrade github.com/portainer/portainer to 2.33.8 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-44882 being exploited?
There is no known exploitation of CVE-2026-44882 in the wild and no public exploit code.
Other vulnerabilities in portainer
Sources
Also known as GHSA-mgq6-4x29-88r3, GO-2026-5505.