CVE-2026-44883 Portainer: JWT accepted in URL query leaks tokens to logs and referers
Portainer accepts JWTs in URL query parameters, leaking tokens to logs and referers, allowing attackers to hijack user sessions and access container environments.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-44883?
CVE-2026-44883 is a high-severity vulnerability in portainer, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer's authentication middleware accepts JWT bearer tokens passed as the ?token=<JWT> URL query parameter on any authenticated API endpoint, in addition to the standard Authorization: Bearer header. URLs are recorded in reverse-proxy access logs, browser history, and HTTP Referer headers on outbound navigation, so any JWT passed this way can be harvested by anyone with access to those logs or by an external site the user subsequently visits. A leaked token grants the full privileges of the user it was issued to, until the token expires (default 8 hours, configurable). The ?token= parameter was used by Portainer's browser-based container attach, exec, and pod shell features, so any user with exec or attach rights on a container was exposed — not only administrators. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.
Weakness: CWE-598
Which versions are affected by CVE-2026-44883?
7 open source packages ship an affected version, including github.com/portainer/portainer. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/portainer/portainer Go | All versions | None |
github.com/portainer/portainer Go | From 2.33.0 | 2.33.8 |
github.com/portainer/portainer Go | From 2.33.0 | 2.33.8 |
github.com/portainer/portainer Go | From 2.39.0 | 2.39.2 |
github.com/portainer/portainer Go | From 2.39.0 | 2.39.2 |
github.com/portainer/portainer Go | From 2.40.0 | 2.41.0 |
1 more packages
github.com/portainer/portainer Go | From 2.40.0 | 2.41.0 |
Products include Portainer Portainer.
How do I fix CVE-2026-44883?
Upgrade github.com/portainer/portainer to a fixed version for your release line: 2.33.8, 2.39.2 or 2.41.0.
Is CVE-2026-44883 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44883 exists.
Other vulnerabilities in portainer
Sources
Also known as GHSA-jvp4-q659-95mj, GO-2026-5480.