# CVE-2026-44883: Portainer: JWT accepted in URL query leaks tokens to logs and referers

> Portainer accepts JWTs in URL query parameters, leaking tokens to logs and referers, allowing attackers to hijack user sessions and access container environments.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-jvp4-q659-95mj, GO-2026-5480

## What is CVE-2026-44883?

CVE-2026-44883 is a high-severity vulnerability in portainer, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer's authentication middleware accepts JWT bearer tokens passed as the ?token=<JWT> URL query parameter on any authenticated API endpoint, in addition to the standard Authorization: Bearer header. URLs are recorded in reverse-proxy access logs, browser history, and HTTP Referer headers on outbound navigation, so any JWT passed this way can be harvested by anyone with access to those logs or by an external site the user subsequently visits. A leaked token grants the full privileges of the user it was issued to, until the token expires (default 8 hours, configurable). The ?token= parameter was used by Portainer's browser-based container attach, exec, and pod shell features, so any user with exec or attach rights on a container was exposed — not only administrators. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.

Weakness: CWE-598 (Use of HTTP Request With Sensitive Query String)

## Which versions are affected by CVE-2026-44883?

7 open source packages ship an affected version, including github.com/portainer/portainer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/portainer/portainer` | Go | All versions | None |
| `github.com/portainer/portainer` | Go | From 2.33.0 | 2.33.8 |
| `github.com/portainer/portainer` | Go | From 2.33.0 | 2.33.8 |
| `github.com/portainer/portainer` | Go | From 2.39.0 | 2.39.2 |
| `github.com/portainer/portainer` | Go | From 2.39.0 | 2.39.2 |
| `github.com/portainer/portainer` | Go | From 2.40.0 | 2.41.0 |
| `github.com/portainer/portainer` | Go | From 2.40.0 | 2.41.0 |

Products: Portainer Portainer.

## How do I fix CVE-2026-44883?

Upgrade github.com/portainer/portainer to a fixed version for your release line: 2.33.8, 2.39.2 or 2.41.0.

## Is CVE-2026-44883 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44883 exists.

## Other vulnerabilities in portainer

- [CVE-2019-16872](https://insights.sbomify.com/CVE-2019-16872/): Missing authorization in n/a (critical 9.9)
- [CVE-2022-24961](https://insights.sbomify.com/CVE-2022-24961/): Missing authorization in n/a (critical 9.8)
- [CVE-2020-24264](https://insights.sbomify.com/CVE-2020-24264/): Missing authorization in n/a (critical 9.8)
- [CVE-2018-19466](https://insights.sbomify.com/CVE-2018-19466/): Information disclosure in n/a (critical 9.8)
- [CVE-2018-19367](https://insights.sbomify.com/CVE-2018-19367/): Auth bypass in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44883 and fix it if it is affected.

What it is: CVE-2026-44883 is a high-severity vulnerability in portainer, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44883 exists.

Affected packages and fixed versions:
- github.com/portainer/portainer (Go): affected all versions; no fix listed
- github.com/portainer/portainer (Go): affected from 2.33.0; fixed in 2.33.8
- github.com/portainer/portainer (Go): affected from 2.33.0; fixed in 2.33.8
- github.com/portainer/portainer (Go): affected from 2.39.0; fixed in 2.39.2
- github.com/portainer/portainer (Go): affected from 2.39.0; fixed in 2.39.2
- github.com/portainer/portainer (Go): affected from 2.40.0; fixed in 2.41.0
- github.com/portainer/portainer (Go): affected from 2.40.0; fixed in 2.41.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44883/ (Markdown: https://insights.sbomify.com/CVE-2026-44883/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44883
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44883
- OSV: https://osv.dev/vulnerability/CVE-2026-44883

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44883/
Summaries are generated and may contain mistakes; the official description above is the record.
