CVE-2026-44891 Netty: Denial of Service via Unbounded Headers in StompSubframeDecoder

High 7.5 Published Updated

Attackers can cause denial of service in STOMP servers by sending unbounded headers, exhausting memory in the Netty library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44891?

CVE-2026-44891 is a high-severity denial of service vulnerability in Netty Netty, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Netty is a network application framework for development of protocol servers and clients. Prior to 4.1.136.Final and 4.2.16.Final, io.netty.handler.codec.stomp.StompSubframeDecoder fails to limit the total number of headers or their cumulative size per frame, and the maxLineLength parameter only restricts individual header lines. An attacker can send a large number of short headers that are accumulated in memory inside DefaultStompHeadersSubframe until the JVM throws an OutOfMemoryError, causing denial of service for servers exposing a STOMP endpoint based on StompSubframeDecoder. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2026-44891?

4 open source packages ship an affected version, including io.netty:netty-codec-stomp. It affects 1 product.

PackageAffectedFixed in
io.netty:netty-codec-stomp MavenAll versions4.1.136.Final
io.netty:netty-codec-stomp MavenAll versions4.1.136.Final
io.netty:netty-codec-stomp MavenFrom 4.2.0.Alpha14.2.16.Final
io.netty:netty-codec-stomp MavenFrom 4.2.0.Alpha14.2.16.Final

Products include Netty Netty.

How do I fix CVE-2026-44891?

Upgrade io.netty:netty-codec-stomp to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-44891 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44891 exists.

All Netty Netty vulnerabilities

Sources

Also known as CLEANSTART-2026-WN14447, CLEANSTART-2026-XB76941, CLEANSTART-2026-YM67930, DEBIAN-CVE-2026-44891, ECHO-7228-fe24-aad3, GHSA-vhch-2wf3-m8rp and 11 more.

Is CVE-2026-44891 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free