# CVE-2026-44891: Netty: Denial of Service via Unbounded Headers in StompSubframeDecoder

> Attackers can cause denial of service in STOMP servers by sending unbounded headers, exhausting memory in the Netty library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** CLEANSTART-2026-WN14447, CLEANSTART-2026-XB76941, CLEANSTART-2026-YM67930, DEBIAN-CVE-2026-44891, ECHO-7228-fe24-aad3, GHSA-vhch-2wf3-m8rp, MINI-2qcr-8p2v-x9vj, MINI-63qw-j7w6-hq77, MINI-9h6m-257w-jr6p, MINI-c3wg-hvpq-vpmh, MINI-cjgc-mjj5-c5w4, MINI-fjr3-mxw8-r5c8, MINI-pfh6-4gcv-w5j7, MINI-q4rh-2vv4-ccxq, MINI-qcfq-wqx5-jc9r, MINI-w48j-fvff-j4h2, UBUNTU-CVE-2026-44891

## What is CVE-2026-44891?

CVE-2026-44891 is a high-severity denial of service vulnerability in Netty Netty, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is a network application framework for development of protocol servers and clients. Prior to 4.1.136.Final and 4.2.16.Final, io.netty.handler.codec.stomp.StompSubframeDecoder fails to limit the total number of headers or their cumulative size per frame, and the maxLineLength parameter only restricts individual header lines. An attacker can send a large number of short headers that are accumulated in memory inside DefaultStompHeadersSubframe until the JVM throws an OutOfMemoryError, causing denial of service for servers exposing a STOMP endpoint based on StompSubframeDecoder. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-44891?

4 open source packages ship an affected version, including io.netty:netty-codec-stomp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-stomp` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-codec-stomp` | Maven | All versions | 4.1.136.Final |
| `io.netty:netty-codec-stomp` | Maven | From 4.2.0.Alpha1 | 4.2.16.Final |
| `io.netty:netty-codec-stomp` | Maven | From 4.2.0.Alpha1 | 4.2.16.Final |

Products: Netty Netty.

## How do I fix CVE-2026-44891?

Upgrade io.netty:netty-codec-stomp to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.

## Is CVE-2026-44891 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44891 exists.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44891 and fix it if it is affected.

What it is: CVE-2026-44891 is a high-severity denial of service vulnerability in Netty Netty, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44891 exists.

Affected packages and fixed versions:
- io.netty:netty-codec-stomp (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-codec-stomp (Maven): affected all versions; fixed in 4.1.136.Final
- io.netty:netty-codec-stomp (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.16.Final
- io.netty:netty-codec-stomp (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.16.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44891/ (Markdown: https://insights.sbomify.com/CVE-2026-44891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44891
- OSV: https://osv.dev/vulnerability/CVE-2026-44891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44891/
Summaries are generated and may contain mistakes; the official description above is the record.
