# CVE-2026-44892: Netty has a Vulnerable Default Configuration Which Leads to Denial of Service via Unbounded HTTP/3 Header Size

> Netty's HTTP/3 codec lacks a default header size limit, allowing attackers to cause memory exhaustion and denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** CLEANSTART-2026-WM08023, DEBIAN-CVE-2026-44892, ECHO-9191-378f-b096, GHSA-c2rx-5r8w-8xr2, MINI-5v2m-wfc4-pwhp, MINI-7gx6-fc2m-2r2v, MINI-cg9c-ghmq-ch97, MINI-h93h-q9gw-27vf, MINI-p93v-r494-p3hh, MINI-qrpw-q36h-6xwf, MINI-vh3c-2r3q-63q5, MINI-xxhq-j822-pv9w, UBUNTU-CVE-2026-44892

## What is CVE-2026-44892?

CVE-2026-44892 is a high-severity denial of service vulnerability in Netty Netty, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is a network application framework for development of protocol servers and clients. Prior to version 4.2.15.Final, the default configuration of the `Http3ConnectionHandler` in the Netty HTTP/3 codec lacks an enforced maximum header size limit. When a peer does not explicitly specify `HTTP3_SETTINGS_MAX_FIELD_SECTION_SIZE`, the implementation defaults to an unbounded limit. This insecure default configuration allows a malicious client or server to send an enormous number of headers, leading to a memory exhaustion Denial of Service via an `OutOfMemoryError`. Version 4.2.15.Final contains a patch.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-44892?

2 open source packages ship an affected version, including io.netty:netty-codec-http3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http3` | Maven | From 4.2.0.Final | 4.2.15.Final |
| `io.netty:netty-codec-http3` | Maven | From 4.2.0.Final | 4.2.15.Final |

Products: Netty Netty.

## How do I fix CVE-2026-44892?

Upgrade io.netty:netty-codec-http3 to 4.2.15.Final or later.

## Is CVE-2026-44892 being exploited?

There is no known exploitation of CVE-2026-44892 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44892 and fix it if it is affected.

What it is: CVE-2026-44892 is a high-severity denial of service vulnerability in Netty Netty, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44892 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-http3 (Maven): affected from 4.2.0.Final; fixed in 4.2.15.Final
- io.netty:netty-codec-http3 (Maven): affected from 4.2.0.Final; fixed in 4.2.15.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44892/ (Markdown: https://insights.sbomify.com/CVE-2026-44892/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44892
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44892
- OSV: https://osv.dev/vulnerability/CVE-2026-44892

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44892/
Summaries are generated and may contain mistakes; the official description above is the record.
