CVE-2026-44893 Netty: HAProxy SSL TLV parsing leaks retained slice on invalid TLV length

High 7.5 Published Updated

An attacker can cause a memory leak and potential denial of service by sending malformed HAProxy SSL TLV data to applications using the Netty codec.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44893?

CVE-2026-44893 is a high-severity denial of service vulnerability in Netty Netty, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Netty is a network application framework for development of protocol servers and clients. In netty-codec-haproxy prior to versions 4.1.135.Final and 4.2.15.Final, when decoding a PP2_TYPE_SSL TLV, HAProxyMessage.readNextTLV() first calls `header.retainedSlice(header.readerIndex(), length)` and only then reads the 1-byte client field and 4-byte verify field. If the attacker sets the TLV length below 5, the subsequent readByte/readInt throws IndexOutOfBoundsException. HAProxyMessageDecoder only catches HAProxyProtocolException around this call, so the IOOBE propagates and the retained slice on the pooled cumulation buffer is never released. Versions 4.1.135.Final and 4.2.15.Final patch the issue.

Weakness: CWE-805, CWE-703

Which versions are affected by CVE-2026-44893?

4 open source packages ship an affected version, including io.netty:netty-codec-haproxy. It affects 1 product.

PackageAffectedFixed in
io.netty:netty-codec-haproxy MavenAll versions4.1.135.Final
io.netty:netty-codec-haproxy MavenAll versions4.1.135.Final
io.netty:netty-codec-haproxy MavenFrom 4.2.0.Final4.2.15.Final
io.netty:netty-codec-haproxy MavenFrom 4.2.0.Final4.2.15.Final

Products include Netty Netty.

How do I fix CVE-2026-44893?

Upgrade io.netty:netty-codec-haproxy to a fixed version for your release line: 4.1.135.Final or 4.2.15.Final.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-44893 being exploited?

There is no known exploitation of CVE-2026-44893 in the wild and no public exploit code.

All Netty Netty vulnerabilities

Sources

Also known as CLEANSTART-2026-RS36042, CLEANSTART-2026-SO96851, CLEANSTART-2026-WP83796, DEBIAN-CVE-2026-44893, ECHO-e271-a55c-dc61, GHSA-cc37-9q2j-3hfv and 29 more.

Is CVE-2026-44893 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free