# CVE-2026-44898: Mistune TOC Anchor Injection XSS

> An attacker can inject arbitrary HTML and scripts into the rendered table of contents by crafting malicious heading text, affecting applications using the Mistune library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 May 2026
- **Updated:** 27 May 2026
- **Also known as:** AZL-88403, CLEANSTART-2026-PO47077, CLEANSTART-2026-QY40587, DEBIAN-CVE-2026-44898, GHSA-6269-cqxg-mhhv, PYSEC-2026-2208, SUSE-SU-2026:2949-1, UBUNTU-CVE-2026-44898

## What is CVE-2026-44898?

CVE-2026-44898 is a medium-severity cross-site scripting vulnerability in lepture mistune, published on 26 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mistune is a Python Markdown parser with renderers and plugins. Prior to 3.2.1, render_toc_ul() builds a <ul> table-of-contents tree from a list of (level, id, text) tuples. Both the id value (used as href="#<id>") and the text value (used as the visible link label) are inserted into <a> tags via a plain Python format string — with no HTML escaping applied to either value. When heading IDs are derived from user-supplied heading text (the standard use-case for readable slug anchors), an attacker can craft a heading whose text breaks out of the href="#..." attribute context, injecting arbitrary HTML tags including <script> blocks directly into the rendered TOC. This vulnerability is fixed in 3.2.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-44898?

3 open source packages ship an affected version, including mistune. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mistune` | PyPI | All versions | 3.2.1 |
| `mistune` | PyPI | From 3.2.0 | 3.2.1 |
| `mistune` | PyPI | From 3.2.0 | 3.2.1 |
| `python-mistune` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 2.0.5-150400.11.8.1 |

Products: Mistune Project Mistune.

## How do I fix CVE-2026-44898?

Upgrade mistune to 3.2.1 or later.

## Is CVE-2026-44898 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44898 exists.

## Other vulnerabilities in lepture mistune

- [CVE-2026-59922](https://insights.sbomify.com/CVE-2026-59922/): Mistune plugins/formatting: quadratic-time parsing on long runs of `~~x~~`, `==x==`, and `^^x^^` markers (strikethrough / mark / insert) (high 7.5)
- [CVE-2026-59925](https://insights.sbomify.com/CVE-2026-59925/): inline_parser: quadratic-time parsing on long runs of `**x**` and `***x***` emphasis pairs (high 7.5)
- [CVE-2026-59928](https://insights.sbomify.com/CVE-2026-59928/): Mistune block_parser: quadratic-time parsing on long lists of repeated reference-link definitions (high 7.5)
- [CVE-2026-59923](https://insights.sbomify.com/CVE-2026-59923/): Mistune: XSS via percent-encoded javascript URI bypass in safe_url() (medium 6.1)
- [CVE-2026-59929](https://insights.sbomify.com/CVE-2026-59929/): Mistune renderers/html.safe_url: HARMFUL_PROTOCOLS list misses legacy and chained schemes that historically chain to `javascript:` execution (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44898 and fix it if it is affected.

What it is: CVE-2026-44898 is a medium-severity cross-site scripting vulnerability in lepture mistune, published on 26 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44898 exists.

Affected packages and fixed versions:
- mistune (PyPI): affected all versions; fixed in 3.2.1
- mistune (PyPI): affected from 3.2.0; fixed in 3.2.1
- mistune (PyPI): affected from 3.2.0; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44898/ (Markdown: https://insights.sbomify.com/CVE-2026-44898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44898
- OSV: https://osv.dev/vulnerability/CVE-2026-44898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44898/
Summaries are generated and may contain mistakes; the official description above is the record.
