{"answers":{"affected":"6 open source packages ship an affected version, including @opentelemetry/auto-instrumentations-node, @opentelemetry/exporter-prometheus and @opentelemetry/sdk-node. It affects 3 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44902 exists.","fix":"Upgrade @opentelemetry/auto-instrumentations-node to 0.75.0 or later.","what":"CVE-2026-44902 is a high-severity denial of service vulnerability in @opentelemetry auto-instrumentations-node, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44902 and fix it if it is affected.\n\nWhat it is: CVE-2026-44902 is a high-severity denial of service vulnerability in @opentelemetry auto-instrumentations-node, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44902 exists.\n\nAffected packages and fixed versions:\n- @opentelemetry/auto-instrumentations-node (npm): affected from 0.55.0; fixed in 0.75.0\n- @opentelemetry/auto-instrumentations-node (npm): affected from 0.55.0; fixed in 0.75.0\n- @opentelemetry/exporter-prometheus (npm): affected all versions; fixed in 0.217.0\n- @opentelemetry/exporter-prometheus (npm): affected all versions; fixed in 0.217.0\n- @opentelemetry/sdk-node (npm): affected from 0.57.0; fixed in 0.217.0\n- @opentelemetry/sdk-node (npm): affected from 0.57.0; fixed in 0.217.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44902/ (Markdown: https://insights.sbomify.com/CVE-2026-44902/index.md)","id":"CVE-2026-44902","markdown":"https://insights.sbomify.com/CVE-2026-44902/index.md","name":"CVE-2026-44902","record":{"aliases":["CLEANSTART-2026-KU07150","ECHO-72ea-32d7-a155","GHSA-q7rr-3cgh-j5r3","MINI-7pfw-97v3-2372","MINI-88c5-whcm-qmwg","MINI-c8h3-7xxv-c789","MINI-g4j4-227p-mc36","MINI-hw6j-22p6-9xh4","MINI-jg77-qpj3-9ppc","MINI-pgpv-8hhv-2qww","MINI-q74c-9wq4-4chp","MINI-r7vh-g4q9-xv58","MINI-rr65-fjp4-gm6h","MINI-w25m-x3xm-m8qr","MINI-xvj3-767f-3q24","ROOT-APP-NPM-CVE-2026-44902"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenTelemetry JS library","requires_auth":"none","summary":"A malformed HTTP request crashes the Node.js process running the OpenTelemetry JS Prometheus exporter due to missing error handling.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opentelemetry\\/auto-instrumentations-node","vendor":"opentelemetry"},{"product":"opentelemetry\\/exporter-prometheus","vendor":"opentelemetry"},{"product":"opentelemetry\\/sdk-node","vendor":"opentelemetry"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-755","name":"Improper Handling of Exceptional Conditions"}],"description":"opentelemetry-js is the OpenTelemetry JavaScript Client. Prior to 0.217.0, a single malformed HTTP request crashes any Node.js process running the OpenTelemetry JS Prometheus exporter. The metrics endpoint (default 0.0.0.0:9464) has no error handling around URL parsing, so a request with an invalid URI causes an uncaught TypeError that terminates the process. This vulnerability is fixed in 0.217.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"opentelemetry-js: Prometheus exporter process crash via malformed HTTP request","id":"CVE-2026-44902","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":6,"n_references":1,"next":{"headline":"Prometheus: Stored XSS via crafted histogram bucket label values in the heatmap display of the old Prometheus web UI","id":"CVE-2026-44903"},"packages":[{"ecosystem":"npm","fixed":["0.75.0"],"introduced":["0.55.0"],"last_affected":[],"package":"@opentelemetry/auto-instrumentations-node","purl":null,"source":"GHSA-q7rr-3cgh-j5r3"},{"ecosystem":"npm","fixed":["0.75.0"],"introduced":["0.55.0"],"last_affected":[],"package":"@opentelemetry/auto-instrumentations-node","purl":"pkg:npm/%40opentelemetry/auto-instrumentations-node","source":"GHSA-q7rr-3cgh-j5r3"},{"ecosystem":"npm","fixed":["0.217.0"],"introduced":["0"],"last_affected":[],"package":"@opentelemetry/exporter-prometheus","purl":null,"source":"GHSA-q7rr-3cgh-j5r3"},{"ecosystem":"npm","fixed":["0.217.0"],"introduced":["0"],"last_affected":[],"package":"@opentelemetry/exporter-prometheus","purl":"pkg:npm/%40opentelemetry/exporter-prometheus","source":"GHSA-q7rr-3cgh-j5r3"},{"ecosystem":"npm","fixed":["0.217.0"],"introduced":["0.57.0"],"last_affected":[],"package":"@opentelemetry/sdk-node","purl":null,"source":"GHSA-q7rr-3cgh-j5r3"},{"ecosystem":"npm","fixed":["0.217.0"],"introduced":["0.57.0"],"last_affected":[],"package":"@opentelemetry/sdk-node","purl":"pkg:npm/%40opentelemetry/sdk-node","source":"GHSA-q7rr-3cgh-j5r3"}],"prev":{"headline":"Wazuh Cluster DAPI Protocol Deserialization of Untrusted Data Remote Code Execution Vulnerability","id":"CVE-2026-44901"},"products":["auto-instrumentations-node","exporter-prometheus","opentelemetry-js","sdk-node"],"published":"2026-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["@opentelemetry","open-telemetry"]},"summary":"A malformed HTTP request crashes the Node.js process running the OpenTelemetry JS Prometheus exporter due to missing error handling.","url":"https://insights.sbomify.com/CVE-2026-44902/"}