CVE-2026-44907 react-server-dom: Denial of Service in Server Functions
Attackers can cause excessive CPU usage and denial of service by sending crafted HTTP requests to React server DOM endpoints.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44907?
CVE-2026-44907 is a high-severity denial of service vulnerability in Meta react-server-dom-parcel, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A denial of service vulnerability could be triggered by sending specially crafted HTTP requests to server function endpoints, this could lead to excessive CPU usage; affecting the following packages: react-server-dom-webpack, react-server-dom-parcel, react-server-dom-turbopack (versions 19.0.0 through 19.0.7, 19.1.0 through 19.1.8, and 19.2.0 through 19.2.7).
Which versions are affected by CVE-2026-44907?
16 open source packages ship an affected version, including react-server-dom-parcel, react-server-dom-turbopack and react-server-dom-webpack.
| Package | Affected | Fixed in |
|---|---|---|
react-server-dom-parcel npm | From 19.1.0 | 19.1.9 |
react-server-dom-parcel npm | From 19.1.0 | 19.1.9 |
react-server-dom-parcel npm | From 19.2.0 | 19.2.8 |
react-server-dom-parcel npm | From 19.2.0 | 19.2.8 |
react-server-dom-turbopack npm | From 19.0.0 | 19.0.8 |
react-server-dom-turbopack npm | From 19.0.0 | 19.0.8 |
10 more packages
react-server-dom-turbopack npm | From 19.1.0 | 19.1.9 |
react-server-dom-turbopack npm | From 19.1.0 | 19.1.9 |
react-server-dom-turbopack npm | From 19.2.0 | 19.2.8 |
react-server-dom-turbopack npm | From 19.2.0 | 19.2.8 |
react-server-dom-webpack npm | From 19.0.0 | 19.0.8 |
react-server-dom-webpack npm | From 19.0.0 | 19.0.8 |
react-server-dom-webpack npm | From 19.1.0 | 19.1.9 |
react-server-dom-webpack npm | From 19.1.0 | 19.1.9 |
react-server-dom-webpack npm | From 19.2.0 | 19.2.8 |
react-server-dom-webpack npm | From 19.2.0 | 19.2.8 |
How do I fix CVE-2026-44907?
Upgrade react-server-dom-parcel to a fixed version for your release line: 19.1.9 or 19.2.8.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-44907 being exploited?
There is no known exploitation of CVE-2026-44907 in the wild and no public exploit code.
Sources
Also known as CLSA-2026-1785204577, CLSA-2026-1792161469, CLSA-2026-1792161491, CLSA-2026-1792161642, CLSA-2026-1792161657, CLSA-2026-1792251862 and 3 more.