# CVE-2026-44907: react-server-dom: Denial of Service in Server Functions

> Attackers can cause excessive CPU usage and denial of service by sending crafted HTTP requests to React server DOM endpoints.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** CLSA-2026-1785204577, CLSA-2026-1792161469, CLSA-2026-1792161491, CLSA-2026-1792161642, CLSA-2026-1792161657, CLSA-2026-1792251862, CLSA-2026-1792267916, CLSA-2026-1792287258, GHSA-wx67-qw84-cm4g

## What is CVE-2026-44907?

CVE-2026-44907 is a high-severity denial of service vulnerability in Meta react-server-dom-parcel, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A denial of service vulnerability could be triggered by sending specially crafted HTTP requests to server function endpoints, this could lead to excessive CPU usage; affecting the following packages: react-server-dom-webpack, react-server-dom-parcel, react-server-dom-turbopack (versions 19.0.0 through 19.0.7, 19.1.0 through 19.1.8, and 19.2.0 through 19.2.7).

## Which versions are affected by CVE-2026-44907?

16 open source packages ship an affected version, including react-server-dom-parcel, react-server-dom-turbopack and react-server-dom-webpack.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-server-dom-parcel` | npm | From 19.1.0 | 19.1.9 |
| `react-server-dom-parcel` | npm | From 19.1.0 | 19.1.9 |
| `react-server-dom-parcel` | npm | From 19.2.0 | 19.2.8 |
| `react-server-dom-parcel` | npm | From 19.2.0 | 19.2.8 |
| `react-server-dom-turbopack` | npm | From 19.0.0 | 19.0.8 |
| `react-server-dom-turbopack` | npm | From 19.0.0 | 19.0.8 |
| `react-server-dom-turbopack` | npm | From 19.1.0 | 19.1.9 |
| `react-server-dom-turbopack` | npm | From 19.1.0 | 19.1.9 |
| `react-server-dom-turbopack` | npm | From 19.2.0 | 19.2.8 |
| `react-server-dom-turbopack` | npm | From 19.2.0 | 19.2.8 |
| `react-server-dom-webpack` | npm | From 19.0.0 | 19.0.8 |
| `react-server-dom-webpack` | npm | From 19.0.0 | 19.0.8 |
| `react-server-dom-webpack` | npm | From 19.1.0 | 19.1.9 |
| `react-server-dom-webpack` | npm | From 19.1.0 | 19.1.9 |
| `react-server-dom-webpack` | npm | From 19.2.0 | 19.2.8 |
| `react-server-dom-webpack` | npm | From 19.2.0 | 19.2.8 |

## How do I fix CVE-2026-44907?

Upgrade react-server-dom-parcel to a fixed version for your release line: 19.1.9 or 19.2.8.

## Is CVE-2026-44907 being exploited?

There is no known exploitation of CVE-2026-44907 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44907 and fix it if it is affected.

What it is: CVE-2026-44907 is a high-severity denial of service vulnerability in Meta react-server-dom-parcel, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44907 in the wild and no public exploit code.

Affected packages and fixed versions:
- react-server-dom-parcel (npm): affected from 19.1.0; fixed in 19.1.9
- react-server-dom-parcel (npm): affected from 19.1.0; fixed in 19.1.9
- react-server-dom-parcel (npm): affected from 19.2.0; fixed in 19.2.8
- react-server-dom-parcel (npm): affected from 19.2.0; fixed in 19.2.8
- react-server-dom-turbopack (npm): affected from 19.0.0; fixed in 19.0.8
- react-server-dom-turbopack (npm): affected from 19.0.0; fixed in 19.0.8
- react-server-dom-turbopack (npm): affected from 19.1.0; fixed in 19.1.9
- react-server-dom-turbopack (npm): affected from 19.1.0; fixed in 19.1.9
- react-server-dom-turbopack (npm): affected from 19.2.0; fixed in 19.2.8
- react-server-dom-turbopack (npm): affected from 19.2.0; fixed in 19.2.8
- react-server-dom-webpack (npm): affected from 19.0.0; fixed in 19.0.8
- react-server-dom-webpack (npm): affected from 19.0.0; fixed in 19.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44907/ (Markdown: https://insights.sbomify.com/CVE-2026-44907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44907
- OSV: https://osv.dev/vulnerability/CVE-2026-44907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44907/
Summaries are generated and may contain mistakes; the official description above is the record.
