# CVE-2026-44911: Apache NiFi: Incorrect Authorization for Configuration Verification Requests

> Users with read access can bypass authorization to submit configuration verification requests with overridden settings in Apache NiFi.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/AU:Y/R:U/V:C/RE:L/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** BIT-nifi-2026-44911, CLEANSTART-2026-NA10191, CLEANSTART-2026-OT47585, GHSA-qvj8-gwpm-4x49, MINI-m4rg-2wq9-4rc6

## What is CVE-2026-44911?

CVE-2026-44911 is a low-severity missing authorization vulnerability in Apache Nifi, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-44911?

3 open source packages ship an affected version, including org.apache.nifi:nifi-web-api and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-web-api` | Maven | From 1.15.0 | 2.10.0 |
| `org.apache.nifi:nifi-web-api` | Maven | From 1.15.0 | 2.10.0 |
| `nifi` | Bitnami | From 1.15.0 | 2.10.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-44911?

Upgrade org.apache.nifi:nifi-web-api to 2.10.0 or later.

## Is CVE-2026-44911 being exploited?

There is no known exploitation of CVE-2026-44911 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44911 and fix it if it is affected.

What it is: CVE-2026-44911 is a low-severity missing authorization vulnerability in Apache Nifi, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44911 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-web-api (Maven): affected from 1.15.0; fixed in 2.10.0
- org.apache.nifi:nifi-web-api (Maven): affected from 1.15.0; fixed in 2.10.0
- nifi (Bitnami): affected from 1.15.0; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44911/ (Markdown: https://insights.sbomify.com/CVE-2026-44911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44911
- OSV: https://osv.dev/vulnerability/CVE-2026-44911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44911/
Summaries are generated and may contain mistakes; the official description above is the record.
