# CVE-2026-44913: Apache NiFi: Improper Escaping of Table Names in CaptureChangeMySQL

> Attackers can inject SQL commands via crafted table names in the CaptureChangeMySQL processor, potentially leading to code execution or data access.

- **Severity:** Medium 5.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/S:P/AU:Y/R:U/V:C/RE:L/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** BIT-nifi-2026-44913, CLEANSTART-2026-JM42748, CLEANSTART-2026-LP47495, GHSA-chxj-gxww-q98w, MINI-c5q3-3q74-v9xg

## What is CVE-2026-44913?

CVE-2026-44913 is a medium-severity SQL injection vulnerability in Apache Nifi, published on 22 Jun 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Improper escaping of database table names in the CaptureChangeMySQL Processor included with Apache NiFi 1.2.0 through 2.9.0 allows for injecting SQL commands using crafted naming. Manual quoted boundaries added in Apache NiFi 1.8.0 narrowed the scope of potential injection options, but did not cover additional strategies. Apache NiFi installations that do not use the CaptureChangeMySQL Processor are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, which incorporates more robust identifier escaping.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-44913?

3 open source packages ship an affected version, including org.apache.nifi:nifi-cdc-mysql-processors and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-cdc-mysql-processors` | Maven | From 1.2.0 | 2.10.0 |
| `org.apache.nifi:nifi-cdc-mysql-processors` | Maven | From 1.2.0 | 2.10.0 |
| `nifi` | Bitnami | From 1.2.0 | 2.10.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-44913?

Upgrade org.apache.nifi:nifi-cdc-mysql-processors to 2.10.0 or later.

## Is CVE-2026-44913 being exploited?

There is no known exploitation of CVE-2026-44913 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44913 and fix it if it is affected.

What it is: CVE-2026-44913 is a medium-severity SQL injection vulnerability in Apache Nifi, published on 22 Jun 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44913 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-cdc-mysql-processors (Maven): affected from 1.2.0; fixed in 2.10.0
- org.apache.nifi:nifi-cdc-mysql-processors (Maven): affected from 1.2.0; fixed in 2.10.0
- nifi (Bitnami): affected from 1.2.0; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44913/ (Markdown: https://insights.sbomify.com/CVE-2026-44913/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44913
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44913
- OSV: https://osv.dev/vulnerability/CVE-2026-44913

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44913/
Summaries are generated and may contain mistakes; the official description above is the record.
